Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 141 раз!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 05 сен 2016, 11:28

Кот_Лета, Ну так прочитайте своё же сообщение, прочитайте текст ошибки, который вы сами же нам показали, и вам станет ясно в чём проблема и что нужно делать.

dusk
Сообщения: 2
C нами: 3 мес 4 дня

Непрочитанное сообщение dusk » 05 сен 2016, 14:32

Максим писал(а):dusk, ваша винда не подходит, вы не настраивали Open Server на работу на внешних IP, при нажатии ничего не происходит поскольку ни на вашей машине ни в настройках Open Server не настроен браузер по умолчанию.


Спасибо, действительно после выставления браузера в настройках программы все начало открываться. подскажите пожалуйста где что настроить чтоб доступ из мира был ? локально сайт запускается а из мира не открывается... вроде все настройки перелистал ну не вижу хоть убейте где это... подскажите пожалуйста мне несведущему где что надо включить...

semenl_1995
Сообщения: 2
C нами: 2 мес 28 дней

Непрочитанное сообщение semenl_1995 » 05 сен 2016, 16:22

Добрый день, скачал и поставил последнюю версию Open Server, но в нем не было экстеншена mongoDB, сам выкачал все, установил extension для php, прописал его в php.ini, но при попытке запуска open servar'a с mongoDB, сервер не запускается, в эрор логе только пишет, что "Не удалось запустить MongoDB" и все.

semenl_1995
Сообщения: 2
C нами: 2 мес 28 дней

Непрочитанное сообщение semenl_1995 » 05 сен 2016, 18:25

semenl_1995 писал(а):Добрый день, скачал и поставил последнюю версию Open Server, но в нем не было экстеншена mongoDB, сам выкачал все, установил extension для php, прописал его в php.ini, но при попытке запуска open servar'a с mongoDB, сервер не запускается, в эрор логе только пишет, что "Не удалось запустить MongoDB" и все.


Забыл упомянуть
Сблорка: php 7, apach-php7+Nginx1.0, MySql 5.7
Операционная система - windows 7 32-bit
http://clip2net.com/s/3BUHkrL - ссылка на логи
http://clip2net.com/s/3BUHwPE - cсылка на php.ini
http://c2n.me/3BUHANN - ссылка на mongodb.conf

cosolom
Сообщения: 1
C нами: 1 год 2 мес

Непрочитанное сообщение cosolom » 06 сен 2016, 10:38

Здравствуйте. Сборка 5.2.5. WinXP SP3. Запуск с модулем MySQL5.7 выбивает ошибку (нужен именно 5.7):
d:\openserver\modules\database\MySQL-5.7\bin\mysqld.exe не является приложением Win32.

Запускаю под учеткой админа. С MySQL5.6 запускается нормально.
В логах пусто.
2016-09-06 09:18:33  --------------------------------------------
2016-09-06 09:18:33  Начало процедуры запуска сервера
2016-09-06 09:18:33  Обновление Hosts файла
2016-09-06 09:18:33  Обновление конфигурации MySQL-5.7
2016-09-06 09:18:33  Обновление конфигурации Sendmail
2016-09-06 09:18:33  Обновление конфигурации PHP-5.3
2016-09-06 09:18:33  Обновление конфигурации PHPMyAdmin
2016-09-06 09:18:33  Обновление конфигурации Apache-2.2
2016-09-06 09:18:33  Запуск MySQL-5.7
2016-09-06 09:18:33  Запуск Apache-2.2
2016-09-06 09:18:33  Проверка состояния сервера
2016-09-06 09:19:11  Не удалось запустить MySQL-5.7
2016-09-06 09:19:11  Сбой запуска!
2016-09-06 09:19:11  --------------------------------------------
2016-09-06 09:19:11  Начало процедуры остановки сервера
2016-09-06 09:19:11  Остановка системных модулей
2016-09-06 09:19:12  Отключение виртуального диска
2016-09-06 09:19:12  Сервер успешно остановлен за 0,781 секунд!

Скрин MySQL лога: http://prntscr.com/cep8o0
Скрин запуска в отладочном режиме: http://prntscr.com/cep84k

Dimash123
Сообщения: 2
C нами: 1 мес 17 дней

Непрочитанное сообщение Dimash123 » 18 окт 2016, 07:09

Здравствуйте. У меня windows server 2008 r2. Версия open server 5.2.5. Но он не запускается
 2016-10-18 09:59:30  --------------------------------------------
2016-10-18 09:59:30  Начало процедуры запуска сервера
2016-10-18 09:59:32  Обновление Hosts файла
2016-10-18 09:59:32  Обновление конфигурации MySQL-5.5
2016-10-18 09:59:32  Обновление конфигурации Sendmail
2016-10-18 09:59:32  Обновление конфигурации PHP-5.3
2016-10-18 09:59:32  Обновление конфигурации PHPMyAdmin
2016-10-18 09:59:32  Обновление конфигурации Apache-2.2
2016-10-18 09:59:32  Запуск MySQL-5.5
2016-10-18 09:59:32  Запуск Apache-2.2
2016-10-18 09:59:32  Проверка состояния сервера
2016-10-18 10:00:05  Не удалось запустить Apache-2.2
2016-10-18 10:00:05  Сбой запуска!
2016-10-18 10:00:05  --------------------------------------------
2016-10-18 10:00:05  Начало процедуры остановки сервера
2016-10-18 10:00:05  Остановка системных модулей
2016-10-18 10:00:06  Отключение виртуального диска
2016-10-18 10:00:06  Сервер успешно остановлен за 0,687 секунд!

Вот mysql отладка
161018  9:59:32 [Note] c:\openserver\modules\database\MySQL-5.5\bin\mysqld.exe (mysqld 5.5.50) starting as process 2404 ...
161018  9:59:32 [Note] Plugin 'FEDERATED' is disabled.
161018  9:59:32 InnoDB: The InnoDB memory heap is disabled
161018  9:59:32 InnoDB: Mutexes and rw_locks use Windows interlocked functions
161018  9:59:32 InnoDB: Compressed tables use zlib 1.2.3
161018  9:59:32 InnoDB: Initializing buffer pool, size = 128.0M
161018  9:59:32 InnoDB: Completed initialization of buffer pool
InnoDB: The first specified data file c:\openserver\userdata\MySQL-5.5\ibdata1 did not exist:
InnoDB: a new database to be created!
161018  9:59:32  InnoDB: Setting file c:\openserver\userdata\MySQL-5.5\ibdata1 size to 10 MB
InnoDB: Database physically writes the file full: wait...
161018  9:59:33  InnoDB: Log file .\ib_logfile0 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile0 size to 64 MB
InnoDB: Database physically writes the file full: wait...
161018  9:59:34  InnoDB: Log file .\ib_logfile1 did not exist: new to be created
InnoDB: Setting log file .\ib_logfile1 size to 64 MB
InnoDB: Database physically writes the file full: wait...
InnoDB: Doublewrite buffer not found: creating new
InnoDB: Doublewrite buffer created
InnoDB: 127 rollback segment(s) active.
InnoDB: Creating foreign key constraint system tables
InnoDB: Foreign key constraint system tables created
161018  9:59:36  InnoDB: Waiting for the background threads to start
161018  9:59:37 InnoDB: 5.5.50 started; log sequence number 0
161018  9:59:37 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
161018  9:59:37 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
161018  9:59:37 [Note] Server socket created on IP: '127.0.0.1'.
161018  9:59:37 [Note] Event Scheduler: Loaded 0 events
161018  9:59:37 [Note] c:\openserver\modules\database\MySQL-5.5\bin\mysqld.exe: ready for connections.
Version: '5.5.50'  socket: ''  port: 3306  MySQL Community Server (GPL)
161018 10:00:05 [Note] c:\openserver\modules\database\MySQL-5.5\bin\mysqld.exe: Normal shutdown

161018 10:00:05 [Note] Event Scheduler: Purging the queue. 0 events
161018 10:00:05  InnoDB: Starting shutdown...
161018 10:00:06  InnoDB: Shutdown completed; log sequence number 1595675
161018 10:00:06 [Note] c:\openserver\modules\database\MySQL-5.5\bin\mysqld.exe: Shutdown complete

Брандмауер и антивирус выключены но все равно

Dimash123
Сообщения: 2
C нами: 1 мес 17 дней

Непрочитанное сообщение Dimash123 » 18 окт 2016, 07:29

Все заработало проблема была в team viewer хоть я его отключил он все равно занимал 80 порт

grishakir
Сообщения: 1
C нами: 1 мес 5 дней

Непрочитанное сообщение grishakir » 30 окт 2016, 12:05

Open Server 5.2.2
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=0
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.6-x64"
httpdriver="Apache-2.4"
mysql_driver="MySQL-5.5"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=2
showfvr=0
showprogs=1
hdomains=0
balloon=0
favorite=0
showswitch=1
debugmode=0
stext=1
sbrowser=1
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser="C:\Users\Григорий\AppData\Local\Yandex\YandexBrowser\Application\browser.exe"
textred="%realprogdir%\progs\_Office\Sublime_text\sublime_text.exe"
filebrowser=""
sfilebrowser=0
maxrequests=0
folders=""

Windows 7 Максимальная SP1
Касперский, при выключении тоже самое
2016-10-30 13:03:52  --------------------------------------------
2016-10-30 13:03:52  Начало процедуры запуска сервера
2016-10-30 13:03:52  Обновление Hosts файла
2016-10-30 13:03:52  Обновление конфигурации MySQL-5.5
2016-10-30 13:03:52  Обновление конфигурации Sendmail
2016-10-30 13:03:52  Обновление конфигурации PHP-5.6-x64
2016-10-30 13:03:52  Обновление конфигурации PHPMyAdmin
2016-10-30 13:03:52  Обновление конфигурации Apache-2.4
2016-10-30 13:03:52  Запуск MySQL-5.5
2016-10-30 13:03:52  Запуск Apache-2.4
2016-10-30 13:03:53  Проверка состояния сервера
2016-10-30 13:04:26  Не удалось запустить Apache-2.4
2016-10-30 13:04:26  Сбой запуска!
2016-10-30 13:04:26  --------------------------------------------
2016-10-30 13:04:26  Начало процедуры остановки сервера
2016-10-30 13:04:26  Остановка системных модулей
2016-10-30 13:04:26  Отключение виртуального диска
2016-10-30 13:04:26  Сервер успешно остановлен за 0,687 секунд!

161030 13:03:53 [Note] i:\openserver\openserver\modules\database\MySQL-5.5\bin\mysqld.exe (mysqld 5.5.50) starting as process 1140 ...
161030 13:03:53 [Note] Plugin 'FEDERATED' is disabled.
161030 13:03:53 InnoDB: The InnoDB memory heap is disabled
161030 13:03:53 InnoDB: Mutexes and rw_locks use Windows interlocked functions
161030 13:03:53 InnoDB: Compressed tables use zlib 1.2.3
161030 13:03:53 InnoDB: Initializing buffer pool, size = 128.0M
161030 13:03:53 InnoDB: Completed initialization of buffer pool
161030 13:03:53 InnoDB: highest supported file format is Barracuda.
161030 13:03:53  InnoDB: Waiting for the background threads to start
161030 13:03:54 InnoDB: 5.5.50 started; log sequence number 1595675
161030 13:03:54 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
161030 13:03:54 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
161030 13:03:54 [Note] Server socket created on IP: '127.0.0.1'.
161030 13:03:54 [Note] Event Scheduler: Loaded 0 events
161030 13:03:54 [Note] i:\openserver\openserver\modules\database\MySQL-5.5\bin\mysqld.exe: ready for connections.
Version: '5.5.50'  socket: ''  port: 3306  MySQL Community Server (GPL)
161030 13:04:26 [Note] i:\openserver\openserver\modules\database\MySQL-5.5\bin\mysqld.exe: Normal shutdown

161030 13:04:26 [Note] Event Scheduler: Purging the queue. 0 events
161030 13:04:26  InnoDB: Starting shutdown...
161030 13:04:26  InnoDB: Shutdown completed; log sequence number 1595675
161030 13:04:26 [Note] i:\openserver\openserver\modules\database\MySQL-5.5\bin\mysqld.exe: Shutdown complete
Вложения
Безымянный1.png

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 30 окт 2016, 17:42

grishakir, Вы включили 32-битный модуль apache и 64-битный модуль PHP, что недопустимо. Модули должны быть одной битности.

Andrew_error
Сообщения: 2
C нами: 1 мес 2 дня

Непрочитанное сообщение Andrew_error » 01 ноя 2016, 21:26

Здравствуйте ! Установил сегодня Open Server (Denwer просто уже взбесил!). Но что-то пошло не так, после установки я поменял версию PHP на 7-ю и Apache для PHP 7, MySQL не трогал оставил 5.5. Запускаю сервер и появляется ошибка: "Запуск программы не возможен, так как на компьютере отсутствует api-ms-crt-runtime-I1-1-0.dll. Попробуйте переустановить программу."(все дополнительные компоненты я установил). В общем сервер отказывается работать. Пробовал ничего не менять в настройках модулей, при этом сервер запускается, но появляется другая ошибка: "504 Gateway Time-out", а когда захожу просто на localhost, появляется пустая страница и иконка Денвера... Насчёт Денвера: я всё удалил (все его файлы), а также почисти файл host (оставил только 127.0.0.1 localhost), но безрезультатно. Посмотрел логи Apach'а и мне кажется, что в этом ошибка (может я ошибаюсь). Вот логи:
2016/11/02 01:17:28 [error] 4492#2604: *1 CreateFile() "w:/modules/system/html/default/favicon.ico" failed (2: The system cannot find the file specified), client: 127.0.0.1, server: , request: "GET /favicon.ico HTTP/1.1", host: "localhost", referrer: "http://localhost/"
2016/11/02 01:18:03 [error] 4492#2604: *1 upstream timed out (10060: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond) while connecting to upstream, client: 127.0.0.1, server: , request: "GET /openserver/ HTTP/1.1", upstream: "http://127.0.0.1:8080/openserver/", host: "localhost"

Прошу вас помочь ! Просто нужно проект доделывать, а тут такая проблема.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость