Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 201 раз!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 28 июн 2016, 21:07

yield, базы до этого были или нет в PostgreSQL? Если это первый запуск модуля (т.е. если баз не было), то видимо инициализация прошла некорректно и в этом случае просто остановите сервер и удалите папку с названием модуля из папки ./userdata/. После этого запустите сервер, инициализация должна пройти нормально. Убедитесь что на диске есть место и что он работает без ошибок.

Если же базы были, то у вас у пропала таблица pg_control и тут вариантов много, сбой бд, проблемы с диском, удалили сами и т.д. В этом случае пробуйте восстановить бд.

yield
Сообщения: 4
C нами: 5 мес 11 дней

Непрочитанное сообщение yield » 30 июн 2016, 12:50

Баз данных ещё не было создано. Я только пытаюсь запустить это дело.
Удалил папку с данными модуля. При запуске сервера вначале появляется окно со скриншота, висит некоторое время, потом появляются два окна из предыдущего сообщения с тем же содержанием, через несколько секунд первое окно закрывается. Содержание логов неизменно.

Структура файлов и каталогов после неудачной инициализации:
PostgreSQL-9.2\base\
PostgreSQL-9.2\base\1\
PostgreSQL-9.2\global\
PostgreSQL-9.2\pg_clog\
PostgreSQL-9.2\pg_multixact\
PostgreSQL-9.2\pg_multixact\members\
PostgreSQL-9.2\pg_multixact\offsets\
PostgreSQL-9.2\pg_notify\
PostgreSQL-9.2\pg_serial\
PostgreSQL-9.2\pg_snapshots\
PostgreSQL-9.2\pg_stat_tmp\
PostgreSQL-9.2\pg_subtrans\
PostgreSQL-9.2\pg_tblspc\
PostgreSQL-9.2\pg_twophase\
PostgreSQL-9.2\pg_xlog\
PostgreSQL-9.2\pg_xlog\archive_status\
PostgreSQL-9.2\pg_hba.conf
PostgreSQL-9.2\pg_notify\0000
PostgreSQL-9.2\PG_VERSION
PostgreSQL-9.2\postgresql.conf
PostgreSQL-9.2\postmaster.pid
Вложения
sdfghjkl.png

yield
Сообщения: 4
C нами: 5 мес 11 дней

Непрочитанное сообщение yield » 06 июл 2016, 12:57

Проблема крылась в разрешениях на доступ к файловой системе. Странно, что остальные программы работают с файлами без проблем.
До этого были странные разрешения. Оставил только систему, администраторов и пользователей. Теперь инициализация спотыкалась сразу, потому что не могла создать папку с данными модуля. Не понятно почему так происходит, ведь сервер запускается от пользователя-администратора, а у группы администраторов полный доступ (владельца я менял на этого пользователя и на группу администраторов - ничего не менялось). Потом я добавил на все объекты полные разрешения конкретно для этого администратора, и взлетело.
Какие идеи, почему, запускаясь из-под администратора, программа говорит будто нет доступа к объектам у которых полный доступ для группы администраторов?
Прилагаю лог PM до момента неудачной инициализации и её скриншот, с полными правами на файлы сервера у администраторов, у пользователей - на чтение. Запуск из-под администратора.
Вложения
40295505d2f5385de93c.png
40295505d2f5385de93c.zip
(456.02 КБ) 16 скачиваний

Аватара пользователя
Zhezkazganetcs
Сообщения: 1
C нами: 4 мес 27 дней

Непрочитанное сообщение Zhezkazganetcs » 14 июл 2016, 13:38

всем здрасти
скачал свежую версию (Open Server 5.2.5), установил, перезагрузил, запустил >>> запустился
НО ничего не происходит, т.е. когда нажимаю на мои сайты >>> localhost то не запускается браузер
также ничего не происходит дополнительно >>> phpmyadmin
т.к. уже не раз запускал на более ранних версиях, то не могу понять почему ничего не происходит и куда копать
перекачивал несколько раз
переустанавливал несколько раз
винда XP
подскажите куда и что смотреть

jdk
Сообщения: 2
C нами: 4 мес 26 дней

Непрочитанное сообщение jdk » 15 июл 2016, 05:19

Добрый день. Импортитовал 29гб БД. Потом решил перезапустить сервер, но он перестал запускаться. До этого все работало без проблем.
При импорте поменял innodb_buffer_pool_size = 1024M, потом пробовал ставить обратно, результат не изменился.
Изображение

Изображение


userdata\profiles\Default.ini
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=0
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.6"
httpdriver="Apache-2.4"
mysql_driver="MySQL-5.5"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=0
favorite=0
showswitch=1
debugmode=1
stext=1
sbrowser=0
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser=""
textred="%realprogdir%\progs\_Office\Notepad++\notepad++.exe"
filebrowser=""
sfilebrowser=0
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""



windows 7, eset node 32 antivirus, под администратором, 4гб оператиной памяти.

Логи
Основной:
2016-07-15 12:10:46  --------------------------------------------
2016-07-15 12:10:46  Начало процедуры запуска сервера
2016-07-15 12:10:46  Обновление Hosts файла
2016-07-15 12:10:46  Обновление конфигурации MySQL-5.5
2016-07-15 12:10:46  Обновление конфигурации Sendmail
2016-07-15 12:10:46  Обновление конфигурации PHP-5.6
2016-07-15 12:10:46  Обновление конфигурации PHPMyAdmin
2016-07-15 12:10:46  Обновление конфигурации Apache-2.4
2016-07-15 12:10:46  Запуск MySQL-5.5
2016-07-15 12:10:46  Запуск Apache-2.4
2016-07-15 12:10:46  Проверка состояния сервера
2016-07-15 12:11:18  Не удалось запустить MySQL-5.5
2016-07-15 12:11:18  Сбой запуска!
2016-07-15 12:11:18  --------------------------------------------
2016-07-15 12:11:18  Начало процедуры остановки сервера
2016-07-15 12:11:18  Остановка системных модулей
2016-07-15 12:11:50  Отключение виртуального диска
2016-07-15 12:11:50  Сервер успешно остановлен за 31,731 секунд!


Apache запросы - пустой

Apache отладка
[Fri Jul 15 12:10:47.386965 2016] [ssl:warn] [pid 4040:tid 224] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:47.386965 2016] [ssl:warn] [pid 4040:tid 224] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:47.530965 2016] [ssl:warn] [pid 4040:tid 224] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:47.530965 2016] [ssl:warn] [pid 4040:tid 224] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:47.559965 2016] [mpm_winnt:notice] [pid 4040:tid 224] AH00455: Apache/2.4.20 (Win32) OpenSSL/1.0.2h configured -- resuming normal operations
[Fri Jul 15 12:10:47.559965 2016] [mpm_winnt:notice] [pid 4040:tid 224] AH00456: Apache Lounge VC11 Server built: Apr  9 2016 11:30:31
[Fri Jul 15 12:10:47.559965 2016] [core:notice] [pid 4040:tid 224] AH00094: Command line: 'c:\\openserver\\modules\\http\\Apache-2.4\\bin\\httpd.exe -d C:/OpenServer/modules/http/Apache-2.4 -f c:\\openserver\\modules\\http\\Apache-2.4\\conf\\httpd.conf'
[Fri Jul 15 12:10:47.561965 2016] [mpm_winnt:notice] [pid 4040:tid 224] AH00418: Parent: Created child process 348
[Fri Jul 15 12:10:47.941965 2016] [ssl:warn] [pid 348:tid 236] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:47.941965 2016] [ssl:warn] [pid 348:tid 236] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:48.075965 2016] [ssl:warn] [pid 348:tid 236] AH01909: localhost:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:48.076965 2016] [ssl:warn] [pid 348:tid 236] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Fri Jul 15 12:10:48.111965 2016] [mpm_winnt:notice] [pid 348:tid 236] AH00354: Child: Starting 32 worker threads.


PHP отладка - пустой

MySQL отладка
160715 12:10:47 [Note] Plugin 'FEDERATED' is disabled.
160715 12:10:47 InnoDB: The InnoDB memory heap is disabled
160715 12:10:47 InnoDB: Mutexes and rw_locks use Windows interlocked functions
160715 12:10:47 InnoDB: Compressed tables use zlib 1.2.3
160715 12:10:47 InnoDB: Initializing buffer pool, size = 1.0G
160715 12:10:47 InnoDB: Completed initialization of buffer pool
160715 12:10:47 InnoDB: highest supported file format is Barracuda.
InnoDB: Log scan progressed past the checkpoint lsn 59256522745
160715 12:10:47  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
InnoDB: Doing recovery: scanned up to log sequence number 59261765120
InnoDB: Doing recovery: scanned up to log sequence number 59267008000
InnoDB: Doing recovery: scanned up to log sequence number 59272250880
InnoDB: Doing recovery: scanned up to log sequence number 59277493760
InnoDB: Doing recovery: scanned up to log sequence number 59282736640
InnoDB: Doing recovery: scanned up to log sequence number 59287979520
InnoDB: Doing recovery: scanned up to log sequence number 59293222400
InnoDB: Doing recovery: scanned up to log sequence number 59298465280
InnoDB: Doing recovery: scanned up to log sequence number 59302237000
160715 12:10:52  InnoDB: Starting an apply batch of log records to the database...
InnoDB: Progress in percents: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88


Почта - пустой

Подскажите пожалуйста, как можно исправить ситуацию?

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 15 июл 2016, 12:54

Zhezkazganetcs, укажите браузер в настройках программы и тогда всё у вас будет открываться.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 15 июл 2016, 12:57

jdk, по всей видимости вы не дождались окончания импорта и "прибили" сервер через таскменеджер. В результате хранилище данных оказалось повреждено. При запуске mysql пытается восстановить хранилище, но Open Server не успевает дождаться и останавливается. Просто добавьте в настройках больше проверок состояния сервера (Настройки - Разное - Количество проверок состояния), это позволит увеличить время ожидания запуска модулей.

jdk
Сообщения: 2
C нами: 4 мес 26 дней

Непрочитанное сообщение jdk » 18 июл 2016, 07:51

Большое спасибо!

Аватара пользователя
t4p2
Сообщения: 30
C нами: 1 год 3 мес

Непрочитанное сообщение t4p2 » 24 июл 2016, 01:50

локально сервер работает, а если подключаются удаленно, пишет Apache/2.2.15 (Cloud Linux) и страницу не открывает. С чем это связано?

WestlE
Сообщения: 2
C нами: 4 мес 24 дня

Непрочитанное сообщение WestlE » 28 июл 2016, 01:43

Доброе время суток уважаемый пользователи.
У меня случилась беда. При перезапуске сервера он не запускается, нашёл проблему когда захотел обновить настройки сервера (галочки проставил, жду перезагрузить и сервер просот вылетает). Может кто-нибудь знает как решить эту проблему?


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя