Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 072 раза!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Ivan777
Сообщения: 1
C нами: 7 мес 16 дней

Непрочитанное сообщение Ivan777 » 22 апр 2016, 15:35

Максим не подскажешь в чем проблема?
Используем phpstorm + php7 + Xdebug 2.4 .
Во всех версиях PHP все работает, а в PHP7 при DEBUG-е нельза обратитьса к атрибутам вложенного обьекта.
Выдает ошибку "Can not get property"
Это твой BUG или PHP7 + Xdebug 2.4?

Warlock
Сообщения: 2
C нами: 7 мес 14 дней

Непрочитанное сообщение Warlock » 24 апр 2016, 19:19

Добрый день,
У меня стоит Windows XP SP3... Для работы мне нужен PHP7
В настройках OpenServer указываю PHP7, запускается - но, выдает ошибку 504 nginx - возможно ли устранить ????

При минимальных настройка запускается и все работает...

Warlock
Сообщения: 2
C нами: 7 мес 14 дней

Непрочитанное сообщение Warlock » 24 апр 2016, 20:22

Просмотр логов (Nginx отладка) выдает сообщение:
[error] 1680#644: *1 upstream timed out (10060: Попытка установить соединение была безуспешной, т.к. от другого компьютера за требуемое время не получен нужный отклик, или было разорвано уже установленное соединение из-за неверного отклика уже подключенного компьютера) while connecting to upstream, client: 127.0.0.1, server: localhost, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8080/", host: "localhost"

DeaTh
Сообщения: 6
C нами: 5 лет 2 мес

Непрочитанное сообщение DeaTh » 25 апр 2016, 08:45

@Warlock - php5.4 последняя поддерживаемая версия для windows xp sp3. Обновляйтесь до более поздних версий ОС.

vlsh
Сообщения: 9
C нами: 2 года 9 мес

Непрочитанное сообщение vlsh » 25 апр 2016, 09:05

вот такое благо выскакиыавет http://c2n.me/3xkC49h
php не является приложением win32
ось ХР СП3 *32

Эдуард7
Сообщения: 3
C нами: 8 мес 2 дня

Непрочитанное сообщение Эдуард7 » 26 апр 2016, 00:43

Доброе время суток всем!!! Я некоторое время писал о проблеме запуска сервера, вот цитата:

Эдуард7 писал(а):Доброе время суток!!! Смотрю проблема не только у меня в чем проблема помогите разобраться ПОЖАЛУЙСТА!!! Ибо нет смысла тогда обновляться на новую версию программы, скачал чисто из за php 7. Все что касается моей OS могу предоставить. Заранее спасибо!!!


Так никто дельного совета не предложил. Выход из ситуации я нашел следующий: Решил поставить windows10 так как моя win7 глючила из за ошибок накопившихся за (примерно) 3 года использования. Установил win 10 сделал первый запуск и все заработало!!!! В итоге имею последнюю OS и рабочею версию Open server а. Всем спасибо и удачных веб разработок!!!!!

Denis77
Сообщения: 1
C нами: 7 мес 11 дней

Непрочитанное сообщение Denis77 » 27 апр 2016, 19:45

Когда нажимаю на флажок запустить вылетает вот такая ошибка:
2016-04-27 19:45:19 --------------------------------------------
2016-04-27 19:45:19 Начало процедуры запуска сервера
2016-04-27 19:45:19 Файл C:\Windows\system32\drivers\etc\hosts недоступен для записи
2016-04-27 19:45:19 Отключите использование HOSTS файла или настройте права доступа
2016-04-27 19:45:19 Сбой запуска!

Прошу помогите!

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 27 апр 2016, 19:52

Сделайте ровно то, что там написано: "Отключите использование HOSTS файла или настройте права доступа"

SergD
Сообщения: 9
C нами: 7 мес 21 день

Непрочитанное сообщение SergD » 27 апр 2016, 23:33

Сам OpenServer запустился, Composer тоже у4становил, установил Ларавель. Вроде бы все в норме. Но после внесения строки: "sleeping-owl/admin": "dev-development" и composer update на панели консоли появляется такое сообщение:
Writing lock file
Generating autoload files
> Illuminate\Foundation\ComposerScripts::postUpdate
> php artisan optimize
Generating optimized class loader
При просмотре видеоурока строки: > Illuminate\Foundation\ComposerScripts::postUpdate не должно быть
в переводе вроде означает, что происходит:Запись файла блокировки и создание файлов автозагрузки. В чем может быть причина и как от неё избавиться?

igrdm
Сообщения: 3
C нами: 7 мес 16 дней

Непрочитанное сообщение igrdm » 28 апр 2016, 08:56

DelphinPRO писал(а):Сделайте ровно то, что там написано: "Отключите использование HOSTS файла или настройте права доступа"


я извиняюсь, но я не являюсь администратором и не могу изменять права доступа HOSTS файла. я пробовал изменить настройки - убрал "основные/требование учетной записи админа", установил галку в "сервер/не вносить изменения в HOSTS файл". но все равно выдает ошибку "Access violation at address 0040AAA3 in module 'Open Server x86.exe'. Read of address 000000384 "
спасибо


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость