Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 172 раза!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Muhammad
Сообщения: 2
C нами: 8 мес 6 дней

Непрочитанное сообщение Muhammad » 02 апр 2016, 13:12

Максим, http://prntscr.com/an53wc, http://prntscr.com/an545y. остальное в порядке

Аватара пользователя
Dgikar
Сообщения: 11
C нами: 4 года 5 мес

Непрочитанное сообщение Dgikar » 02 апр 2016, 23:42

Версия проблемного OS - 5.1.1. Давненько им не пользовался - просто валялся на компе на всякий. Пользуюсь в основном версиями более новее и одной более старой проблемного OS. Все версии, запускаются и работают без нареканий, а вот этот...

Когда запускается, то в диспетчере задач появляются Apache HTTP Server (32 bit) и mysqld.exe (32 bit). Если в OS нажать на "Выход", то в диспетчере задач, Apache HTTP Server (32 bit) и mysqld.exe (32 bit) так и остаются. Помогает только ручное снятие задачи...

Подскажите плз, чем он "заболел" и как его "вылечить"?

Заранее благодарю

screens.png
Скрины всех чёрных окон при запуске


Содержимое файла userdata\profiles\Default.ini:
[main]
start=10
allow=1
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=0
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.3"
httpdriver="Apache-2.2"
mysql_driver="MySQL-5.5"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=2
showfvr=0
showprogs=1
hdomains=1
balloon=1
favorite=0
showswitch=1
debugmode=1
stext=0
sbrowser=0
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser=""
textred=""
filebrowser=""
sfilebrowser=0
fzone=none
speed=0
maxrequests=0
upurl=http://open-server.ru/update/
durl=http://open-server.ru/download/
folders="public_html htdocs httpdocs"

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""


Параметры системы:
- Windows 10 x64;
- работаю не под администратором;
- антивирус - Norton Security v. 22.6.0.142;
- фаерволов - нет.

Содержимое вкладок логов:
Основной:
2016-04-02 23:11:56  --------------------------------------------
2016-04-02 23:11:56  Начало процедуры запуска сервера
2016-04-02 23:11:56  Создание виртуального диска
2016-04-02 23:11:56  Обновление Hosts файла
2016-04-02 23:11:56  Обновление конфигурации MySQL-5.5
2016-04-02 23:11:56  Обновление конфигурации Sendmail
2016-04-02 23:11:56  Обновление конфигурации PHP-5.3
2016-04-02 23:11:56  Обновление конфигурации PHPMyAdmin
2016-04-02 23:11:56  Обновление конфигурации Apache-2.2
2016-04-02 23:11:56  Запуск MySQL-5.5
2016-04-02 23:11:56  Запуск Apache-2.2
2016-04-02 23:11:56  Проверка состояния сервера
2016-04-02 23:12:08  Не удалось запустить MySQL-5.5
2016-04-02 23:12:08  Сбой запуска!
2016-04-02 23:12:08  --------------------------------------------
2016-04-02 23:12:08  Начало процедуры остановки сервера
2016-04-02 23:12:08  Остановка системных модулей
2016-04-02 23:12:08  Отключение виртуального диска
2016-04-02 23:12:08  Веб-сервер успешно остановлен!


Apache запросы:
default: 127.0.0.1 [02/Apr/2016:23:11:58 +0300] "GET /openserver/check.html HTTP/1.0" 200 18 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"
default: 127.0.0.1 [02/Apr/2016:23:11:58 +0300] "GET /openserver/check.php HTTP/1.0" 200 18 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0"


Apache отладка:
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Sat Apr 02 23:11:57 2016] [notice] mod_bw : Memory Allocated 0 bytes (each conf takes 40 bytes)
[Sat Apr 02 23:11:57 2016] [notice] mod_bw : Version 0.92 - Initialized [0 Confs]
[Sat Apr 02 23:11:57 2016] [notice] mod_bw : Supported resolution for Timers [ Min: 1 Max: 1000000 ]
[Sat Apr 02 23:11:57 2016] [notice] mod_bw : Enabling High resolution timers [ 1 ms ]
[Sat Apr 02 23:11:57 2016] [notice] Apache/2.2.27 (Win32) mod_ssl/2.2.27 OpenSSL/0.9.8za mod_bw/0.92 configured -- resuming normal operations
[Sat Apr 02 23:11:57 2016] [notice] Server built: Mar 21 2014 10:41:53
[Sat Apr 02 23:11:57 2016] [notice] Parent: Created child process 6676
[Sat Apr 02 23:11:57 2016] [notice] Disabled use of AcceptEx() WinSock2 API
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Apr 02 23:11:57 2016] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Sat Apr 02 23:11:58 2016] [notice] mod_bw : Memory Allocated 0 bytes (each conf takes 40 bytes)
[Sat Apr 02 23:11:58 2016] [notice] mod_bw : Version 0.92 - Initialized [0 Confs]
[Sat Apr 02 23:11:58 2016] [notice] mod_bw : Supported resolution for Timers [ Min: 1 Max: 1000000 ]
[Sat Apr 02 23:11:58 2016] [notice] mod_bw : Enabling High resolution timers [ 1 ms ]
[Sat Apr 02 23:11:58 2016] [notice] Child 6676: Child process is running
[Sat Apr 02 23:11:58 2016] [notice] Child 6676: Acquired the start mutex.
[Sat Apr 02 23:11:58 2016] [notice] Child 6676: Starting 32 worker threads.
[Sat Apr 02 23:11:58 2016] [notice] Child 6676: Listening on port 443.
[Sat Apr 02 23:11:58 2016] [notice] Child 6676: Listening on port 80.


PHP отладка - пусто

MySQL отладка:
160402 23:11:56 [Note] Plugin 'FEDERATED' is disabled.
160402 23:11:56 InnoDB: The InnoDB memory heap is disabled
160402 23:11:56 InnoDB: Mutexes and rw_locks use Windows interlocked functions
160402 23:11:56 InnoDB: Compressed tables use zlib 1.2.3
160402 23:11:56 InnoDB: Initializing buffer pool, size = 20.0M
160402 23:11:56 InnoDB: Completed initialization of buffer pool
160402 23:11:56 InnoDB: highest supported file format is Barracuda.
160402 23:11:57  InnoDB: Waiting for the background threads to start
160402 23:11:58 InnoDB: 5.5.38 started; log sequence number 644770633
160402 23:11:58 [Note] Recovering after a crash using mysql-bin
160402 23:11:58 [Note] Starting crash recovery...
160402 23:11:58 [Note] Crash recovery finished.
160402 23:11:59 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
160402 23:11:59 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
160402 23:11:59 [Note] Server socket created on IP: '127.0.0.1'.
160402 23:11:59 [Note] Event Scheduler: Loaded 0 events
160402 23:11:59 [Note] W:\modules\database\MySQL-5.5\bin\mysqld.exe: ready for connections.
Version: '5.5.38-log'  socket: ''  port: 3306  MySQL Community Server (GPL)


Почта - пусто

fluoro
Сообщения: 3
C нами: 8 мес 9 дней

Непрочитанное сообщение fluoro » 03 апр 2016, 16:48

На виртуалке все работало нормально, перенес на физический и вот:

Изображение


Изображение


Винда и там и там 2012. Все доп-пакеты установлены. Пробовал dll-ки подменить, вообще весь сервак уронил :lol:

Эдуард7
Сообщения: 3
C нами: 8 мес 2 дня

Непрочитанное сообщение Эдуард7 » 06 апр 2016, 14:27

Доброе время суток!!!! Специально зарегистрировался на этом форуме во первых чтобы поблагодарить Вас Максим за Ваш труд и заодно сообщить о проблеме:

Скачал Open Server версию 5.2.4 установил в новую директорию так как стоит версия 5.2.2, сделал первый запуск, перезагрузил компьютер, и в настройках выбрал Apache-PHP-7, PHP-7, MySQL-5.7 и сервер не запускается.

Вот лог:

2016-04-06 12:10:54 --------------------------------------------
2016-04-06 12:10:54 Начало процедуры запуска сервера
2016-04-06 12:10:54 Создание виртуального диска
2016-04-06 12:10:54 Обновление Hosts файла
2016-04-06 12:10:54 Обновление конфигурации MySQL-5.7
2016-04-06 12:10:54 Обновление конфигурации Sendmail
2016-04-06 12:10:54 Обновление конфигурации PHP-7
2016-04-06 12:10:54 Обновление конфигурации PHPMyAdmin
2016-04-06 12:10:54 Обновление конфигурации Apache-PHP-7
2016-04-06 12:10:54 Запуск MySQL-5.7
2016-04-06 12:10:54 Запуск Apache-PHP-7
2016-04-06 12:10:54 Проверка состояния сервера
2016-04-06 12:11:29 Не удалось запустить Apache-PHP-7
2016-04-06 12:11:29 Сбой запуска!
2016-04-06 12:11:29 --------------------------------------------
2016-04-06 12:11:29 Начало процедуры остановки сервера
2016-04-06 12:11:29 Остановка системных модулей
2016-04-06 12:11:31 Отключение виртуального диска
2016-04-06 12:11:31 Сервер успешно остановлен за 2,028 секунд!

Выбрал в настройках отладочный режим вот что мне свалилось в консоль

w:\modules\http\Apache-PHP-7>"w:\modules\http\Apache-PHP-7\bin\httpd.exe" -f "w:
\modules\http\Apache-PHP-7\conf\httpd.conf"

w:\modules\http\Apache-PHP-7>PAUSE

И все, что надо я так и не пойму ПОМОГИТЕ ПОЖАЛУЙСТА!!!!
Стоит у меня Windows 7 64 бита
Пробовал с 64 битными версиями такая же проблема.
Из старой версии Open Server я вышел предварительно. С PHP 5.6 и Apache-2.4 все работает нормально.

Заранее спасибо!!!!!

Ilkar
Сообщения: 1
C нами: 8 мес 2 дня

Непрочитанное сообщение Ilkar » 06 апр 2016, 15:13

аналогичная проблема имеется (Apache-PHP-7, PHP-7, MySQL-5.7, Windows 7 64 бита). Сразу после старта сервера выдает ошибку:
QIP Shot - Screen 010.jpg


потом происходит остановка сервера. Пробовал делать это

Максим писал(а): В этом случае вручную установить:
/modules/system/setup-0.bat
/modules/system/setup-1.exe
/modules/system/setup-2.exe
+ перезагрузка.


не помогает

knizom
Сообщения: 3
C нами: 1 год

Непрочитанное сообщение knizom » 06 апр 2016, 20:02

knizom писал(а):Здравствуйте.
У мена установлена версия 5.2.2. Недавно перешел с Денвера.
Все прекрасно работает, ТОЛЬКО с учетной записью Админа.
А при запуске с ограниченными правами типа учетной записи, выводит ниже указанную ошибку.
Что нужное сделать чтобы сервер запускался и работал с пользователем ограниченными правами. На работе у меня ограниченные права на XP SP3.

RS: На файл hosts имеется право изменения для этого обычного пользователя.


Данная проблема осталась и в последней версии. Пожалуйста подскажите как устранить проблему.
Вложения
error.JPG

Эдуард7
Сообщения: 3
C нами: 8 мес 2 дня

Непрочитанное сообщение Эдуард7 » 07 апр 2016, 17:23

Доброе время суток!!! Смотрю проблема не только у меня в чем проблема помогите разобраться ПОЖАЛУЙСТА!!! Ибо нет смысла тогда обновляться на новую версию программы, скачал чисто из за php 7. Все что касается моей OS могу предоставить. Заранее спасибо!!!

knizom
Сообщения: 3
C нами: 1 год

Непрочитанное сообщение knizom » 12 апр 2016, 05:05

knizom писал(а):Данная проблема осталась и в последней версии. Пожалуйста подскажите как устранить проблему.

Как пользоваться с сервером при типе учетной записи с ограниченными правами.
На сайте у Вас написано что это возможно. На форуме не нашел посвященной темы.
Третий раз прошу помочь. скрин ошибки в предыдущих сообщениях.
ОС: XP SP3,
hosts: разрешенный на изменения,

rom111419
Сообщения: 1
C нами: 7 мес 16 дней

Непрочитанное сообщение rom111419 » 22 апр 2016, 09:54

NGINX не запускается.

Выдает следующее:
nginx: [alert] could not open error log file: CreateFile() "logs/error.log" f
ailed (3: The system cannot find the path specified)
2016/04/22 09:47:42 [emerg] 3996#5268: CreateFile() "w:\/conf/nginx.conf" fai
led (3: The system cannot find the path specified)
Current directory:
w:\
Command to be executed:
"w:\modules\http\Nginx-1.9\nginx.exe"


Вопрос
Мне создавать папки которые пишет консоль или есть другое решение?
Спасибо!

igrdm
Сообщения: 3
C нами: 7 мес 16 дней

Непрочитанное сообщение igrdm » 22 апр 2016, 10:22

SeoVoodoo писал(а):Вобщем похоже, что у меня стандартная проблема, но решить её не получается.

Вот что пишет:
2016-03-30 11:23:39 --------------------------------------------
2016-03-30 11:23:39 Начало процедуры запуска сервера
2016-03-30 11:23:40 Файл C:\Windows\system32\drivers\etc\hosts недоступен для записи
2016-03-30 11:23:40 Отключите использование HOSTS файла или настройте права доступа
2016-03-30 11:23:40 Сбой запуска!
--------------------------------------------------

я извиняюсь, но я не являюсь администратором и не могу изменять права доступа HOSTS файла. я пробовал изменить настройки - убрал "основные/требование учетной записи админа", установил галку в "сервер/не вносить изменения в HOSTS файл". но все равно выдает ошибку "Access violation at address 0040AAA3 in module 'Open Server x86.exe'. Read of address 000000384 "
спасибо


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость