Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 114 раз!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 23 апр 2015, 22:11

VarrkaN писал(а):Unhandled Exception


Обычно такая ошибка появляется когда запускают новый файл со старыми конфигами, т.е. обновляются неправильно, например не читая инструкции к патчу (если обновлялись патчами).

Сомневаюсь что указанная программа виновата, хотя всё может быть.

dev
Сообщения: 2
C нами: 1 год 7 мес

Непрочитанное сообщение dev » 24 апр 2015, 15:32

Возникает ошибка при запуске OpenServer 5.2.2 Professional

Default.ini
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=0
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.5"
httpdriver="Apache-2.4"
mysql_driver="MySQL-5.5"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=1
favorite=0
showswitch=1
debugmode=0
stext=0
sbrowser=0
email=0
vdisk=W
selfhosts=1
webdir="domains"
browser=""
textred=""
filebrowser=""
sfilebrowser=0
fzone=none
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""


main.log
2015-04-24 15:28:26  --------------------------------------------
2015-04-24 15:28:26  Начало процедуры запуска сервера
2015-04-24 15:28:26  Обновление конфигурации MySQL-5.5
2015-04-24 15:28:26  Обновление конфигурации Sendmail
2015-04-24 15:28:26  Обновление конфигурации PHP-5.5
2015-04-24 15:28:26  Обновление конфигурации PHPMyAdmin
2015-04-24 15:28:26  Обновление конфигурации Apache-2.4
2015-04-24 15:28:26  Запуск MySQL-5.5
2015-04-24 15:28:26  Запуск Apache-2.4
2015-04-24 15:28:26  Проверка состояния сервера
2015-04-24 15:28:28  Cервер успешно запущен за 1,654 секунд!


Изображение


Искал в интернете эту дллку. Это что-то связанное с апачем, скачал, поставил в modules/http/apache 2.4/bin/ и сервер запустился без ошибок. Но после ребута посыпалась сотня ошибок в духе "Точка входа в процедуру не найдена..."
Эта ошибка просто раздражает меня. Подскажите, как её исправить. Если потребуется предоставить ещё какие-либо логи, сделаю

dev
Сообщения: 2
C нами: 1 год 7 мес

Непрочитанное сообщение dev » 04 май 2015, 22:16

Может мне кто-нибудь ответит? Пытаюсь перевести на nginx, не найден libapr-1.dll

Kamik
Сообщения: 4
C нами: 1 год 7 мес

Непрочитанное сообщение Kamik » 06 май 2015, 06:01

Не запускается OpenServer.
Винда чистая, свеже-установленная. MS V C++ установлены
[spoiler="Содержимое профиля"]
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=0
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.3"
httpdriver="Apache-2.2"
mysql_driver="MySQL-5.5"
pg_driver="none"
mongo_driver="none"
memcachedriver="none"
redisdriver="none"
dnsdriver="none"
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=1
favorite=0
showswitch=1
debugmode=0
stext=1
sbrowser=1
email=0
vdisk=W
selfhosts=0
webdir=domains
browser="%realprogdir%\progs\_Internet\GoogleChromePortable\GoogleChromePortable.exe"
textred="%realprogdir%\progs\_Office\Notepad2\Notepad2.exe"
filebrowser=""
sfilebrowser=0
fzone=none
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=
smtp_port=
auth_username=
auth_password=
smtp_ssl=0
pop3_server=
pop3_username=
pop3_password=
force_sender=
[/spoiler]

Верхняя ошибка появляется при запуске OpenServer x64, нижняя - при запуске OpenServer x32.
Под админом, антивирей\брэндмауэров нет, запуск от имени админа делал, в режиме совместимости тоже.
[spoiler="Подробный скрин"]
Изображение
[/spoiler]

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 06 май 2015, 23:37

dev, научитесь пользоваться поиском по форуму.

[upd=1430944843][/upd]
Kamik, в сообщении же указано, не хватает системных ресурсов. Памяти видимо или еще чего-то. Так же убедитесь что вы запускаете программу на WinXP SP3 или выше, судя по скриншоту у вас какая-то странная система.

Kamik
Сообщения: 4
C нами: 1 год 7 мес

Непрочитанное сообщение Kamik » 08 май 2015, 02:41

Максим писал(а):
[upd=1430944843][/upd]
Kamik, в сообщении же указано, не хватает системных ресурсов. Памяти видимо или еще чего-то. Так же убедитесь что вы запускаете программу на WinXP SP3 или выше, судя по скриншоту у вас какая-то странная система.


хД система странная =))
Windows Server 2008 R2 Standart SP1
ОЗУ 4 Гб
Проц Xeon E3-1220

Чего может не хватать? Это полноценный стоечный сервер

NiTr0FlAsH
Сообщения: 1
C нами: 1 год 7 мес

Непрочитанное сообщение NiTr0FlAsH » 09 май 2015, 22:29

Дорогие друзья, не работает программа. Пишет сначала "Запуск сервера", а через 30-40 сек "Остановка сервера". Что делать? У меня сайт на хостинге висит. Помогите, пожалуйста.

domjik
Сообщения: 10
C нами: 1 год 6 мес

Непрочитанное сообщение domjik » 11 май 2015, 04:47

Добрый день!

Все работало, пока не создал третий сайт. Теперь вылетает exception error, полагаю, при запуске bind-а. conf-файл зоны не создался (не пришлю). После удаления третьего сайта, все заработало.

main.log
2015-05-11 07:24:37  --------------------------------------------
2015-05-11 07:24:37  Начало процедуры запуска сервера
2015-05-11 07:24:37  Обновление Hosts файла
2015-05-11 07:24:37  Обновление конфигурации MySQL-5.5
2015-05-11 07:24:37  Обновление конфигурации Bind-9.10


dns.conf
options {
directory "e:/web/openserver/userdata/Bind-9.10";
allow-transfer  { none; };
# allow-recursion { 192.168.1.10; 127.0.0.1; 10.0.0.0/8; 169.254.0.0/16; 172.16.0.0/12; 192.168.0.0/16; };
allow-recursion { any; };
allow-query { any; };
recursion yes;
version "DNS";
max-cache-size 30M;
listen-on-v6 { none; };
listen-on { 192.168.1.10; };
notify no;
dnssec-enable no;
pid-file "e:/web/openserver/userdata/temp/named.pid";
session-keyfile "e:/web/openserver/userdata/Bind-9.10/session.key";
managed-keys-directory "e:/web/openserver/userdata/Bind-9.10/keys";
};

controls {};

logging {
channel log { file "e:/web/openserver/userdata/logs/Bind-9.10.log" versions 2 size 3m; print-time yes; print-category yes; print-severity yes;};
category default { log; };
category queries { log; };
};


zone "." IN { type hint; file "e:/web/openserver/userdata/Bind-9.10/rfczones/root.zone"; };
zone "localhost.localdomain" IN { type master; file "e:/web/openserver/userdata/Bind-9.10/rfczones/named.localhost"; allow-update { none; }; };
zone "localhost" IN { type master; file "e:/web/openserver/userdata/Bind-9.10/rfczones/named.localhost"; allow-update { none; }; };


default.ini
[main]
start=30
allow=0
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=192.168.1.10
http_log=1
mysql_log=1
postgresql_log=0
mongodb_log=0
dns_log=1
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.3"
httpdriver="Apache-2.2"
mysql_driver="MySQL-5.5"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver="Bind-9.10"
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=1
favorite=0
showswitch=1
debugmode=0
stext=1
sbrowser=1
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser="%realprogdir%\progs\_Internet\GoogleChromePortable\GoogleChromePortable.exe"
textred="%realprogdir%\progs\_Office\Notepad2\Notepad2.exe"
filebrowser=""
sfilebrowser=0
fzone=none
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""


[upd=1431309442][/upd]
Экспериментальным путем выяснил, что дело не в количестве сайтов, а в их названии. Если два имеющихся сайта представляют собой два домена 3-го уровня на базе одного домена 2-го уровня, например:

aaa.site.ru
bbb.site.ru

- вылетает этот exception error.
Вложения
2015-05-11_openserver_error1.png

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 11 май 2015, 10:07

domjik, спасибо, проблему подтверждаю. Будет исправлено в следующей версии Open Server.

Claud
Сообщения: 1
C нами: 1 год 6 мес

Непрочитанное сообщение Claud » 11 май 2015, 23:49

Версия 5.2.2

Время от времени возникает следующая неприятность. При перезагрузке сервер долго думает, потом погибает - вообще без сообщений (из статус бара windows иконка следовательно пропадает и в диспетчере задач тоже ни чего нет). Логичная попытка снова запустить open-server. Само приложение запускается, но вот запустить web сервер уже не выходит. Вылезает сообщение, что виртуальный диск, который указан в настройках уже занят (при падение сервера он остается примонтированным).

Мне помогает только перезапуск компьютера, что не очень удобно.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость