Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 831 раз!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
dropbox_001
Сообщения: 3
C нами: 3 года

Непрочитанное сообщение dropbox_001 » 25 ноя 2013, 21:12

Неожидал такой быстрый ответ и желание помочь. Я решил чем проблему решать лучше ее обойти. Поставил ее на виртуальной машине - все заработало (правда в агрессивном режиме). Докумнетация на опен сервер хорошая, но не для нуба. я просто изначально испугался что делаю что то не так, так как не понял некоторых пунктов из инструкции.
Еще раз спасибо за желание помочь. Долгой жизни вашим проектам!

weblive
Сообщения: 1
C нами: 3 года

Непрочитанное сообщение weblive » 04 дек 2013, 22:47

Добрый вечер
Может кому поможет.
Наткнулся на похожую проблему как http://open-server.ru/forum/viewtopic.php?p=8873#p8873, сервер запускался все работало за исключением того что через некоторое время(в зависимости от состояния количества проверок состояния сервера) он останавливался по непонятной мне причине(до этого два месяца работал без нареканий). После трех часов поисков проблемы была найдена причина сбоя, она заключалась в запущеной службе StaffCop(ltvsrv.exe), которую установил один умник(завтра будем выяснять кто), котороя блокировала обращение openserver к mysql.
Поэтому при появление сообщений в логах 'Проверка состояния сервера. Не удалось запустить MySQL...' проверьте не установлен ли у Вас StaffCop.

kost757
Сообщения: 11
C нами: 3 года 5 мес

Непрочитанное сообщение kost757 » 21 дек 2013, 02:21

На вин 8,1 в новой версии неработают модели php 5,2


5,2:
2013-12-21 04:13:29  --------------------------------------------
2013-12-21 04:13:29  Начало процедуры запуска сервера
2013-12-21 04:13:29  Обновление Hosts файла
2013-12-21 04:13:29  Обновление конфигурации MySQL-5.5.35
2013-12-21 04:13:29  Обновление конфигурации MongoDB-2.4.8
2013-12-21 04:13:29  Обновление конфигурации Sendmail
2013-12-21 04:13:29  Обновление конфигурации PHP-5.2.17
2013-12-21 04:13:29  Обновление конфигурации PHPMyAdmin
2013-12-21 04:13:29  Обновление конфигурации PHPMyAdmin
2013-12-21 04:13:29  Обновление конфигурации Apache-2.2.26
2013-12-21 04:13:29  Запуск MySQL-5.5.35
2013-12-21 04:13:29  Запуск MongoDB-2.4.8
2013-12-21 04:13:29  Запуск Apache-2.2.26
2013-12-21 04:13:29  Проверка состояния сервера
2013-12-21 04:14:07  Не удалось запустить Apache-2.2.26
2013-12-21 04:14:07  Сбой запуска!
2013-12-21 04:14:07  --------------------------------------------
2013-12-21 04:14:07  Начало процедуры остановки сервера
2013-12-21 04:14:07  Остановка системных модулей
2013-12-21 04:14:09  Отключение виртуального диска
2013-12-21 04:14:09  Веб-сервер успешно остановлен!


[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:30 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Sat Dec 21 04:13:31 2013] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)


C:\OpenServer\modules\database\MySQL-5.5.35\bin\mysqld.exe, Version: 5.5.35-log (MySQL Community Server (GPL)). started with:
TCP Port: 3306, Named Pipe: (null)
Time                 Id Command    Argument

Sat Dec 21 04:13:30.154 BackgroundJob starting: DataFileSync
Sat Dec 21 04:13:30.155 shardObjTest passed
Sat Dec 21 04:13:30.155 isInRangeTest passed
Sat Dec 21 04:13:30.155 shardKeyTest passed
Sat Dec 21 04:13:30.155 versionArrayTest passed
Sat Dec 21 04:13:30.159 [initandlisten] MongoDB starting : pid=3528 port=27017 dbpath=C:\OpenServer\userdata\MongoDB-2.4.8 32-bit host=Konstantin-PC
Sat Dec 21 04:13:30.159 [initandlisten]
Sat Dec 21 04:13:30.159 [initandlisten] ** NOTE: This is a 32 bit MongoDB binary.
Sat Dec 21 04:13:30.159 [initandlisten] **       32 bit builds are limited to less than 2GB of data (or less with --journal).
Sat Dec 21 04:13:30.160 [initandlisten] **       See http://dochub.mongodb.org/core/32bit
Sat Dec 21 04:13:30.160 [initandlisten]
Sat Dec 21 04:13:30.160 [initandlisten] db version v2.4.8
Sat Dec 21 04:13:30.160 [initandlisten] git version: a350fc38922fbda2cec8d5dd842237b904eafc14
Sat Dec 21 04:13:30.160 [initandlisten] build info: windows sys.getwindowsversion(major=6, minor=0, build=6002, platform=2, service_pack='Service Pack 2') BOOST_LIB_VERSION=1_49
Sat Dec 21 04:13:30.160 [initandlisten] allocator: system
Sat Dec 21 04:13:30.160 [initandlisten] options: { bind_ip: "127.0.0.1", config: "C:\OpenServer\userdata\temp\config\mongodb.conf", dbpath: "C:\OpenServer\userdata\MongoDB-2.4.8", ipv6: "no", journal: "yes", logappend: true, logpath: "C:\OpenServer\userdata\logs\MongoDB-2.4.8_error.log", nohttpinterface: "true", noprealloc: "true", port: 27017, smallfiles: "true", verbose: "true" }
Sat Dec 21 04:13:30.195 [initandlisten] journal dir=C:\OpenServer\userdata\MongoDB-2.4.8\journal
Sat Dec 21 04:13:30.196 [initandlisten] recover : no journal files present, no recovery needed
Sat Dec 21 04:13:30.237 [initandlisten] opening db:  local
Sat Dec 21 04:13:30.239 [initandlisten] enter repairDatabases (to check pdfile version #)
Sat Dec 21 04:13:30.239 [initandlisten]    local
Sat Dec 21 04:13:30.240 [initandlisten] done repairDatabases
Sat Dec 21 04:13:30.240 [initandlisten] run command local.$cmd { create: "startup_log", size: 10485760, capped: true }
Sat Dec 21 04:13:30.240 [initandlisten] opening db:  local
Sat Dec 21 04:13:30.240 BackgroundJob starting: snapshot
Sat Dec 21 04:13:30.240 BackgroundJob starting: ClientCursorMonitor
Sat Dec 21 04:13:30.241 BackgroundJob starting: PeriodicTask::Runner
Sat Dec 21 04:13:30.241 BackgroundJob starting: TTLMonitor
Sat Dec 21 04:13:30.241 [initandlisten] create collection local.startup_log { create: "startup_log", size: 10485760, capped: true }
Sat Dec 21 04:13:30.241 [initandlisten] command local.$cmd command: { create: "startup_log", size: 10485760, capped: true } ntoreturn:1 keyUpdates:0  reslen:75 1ms
Sat Dec 21 04:13:30.241 [initandlisten] insert local.startup_log ninserted:1 keyUpdates:0  0ms
Sat Dec 21 04:13:30.242 [initandlisten] waiting for connections on port 27017
Sat Dec 21 04:14:07.618 Ctrl-C signal
Sat Dec 21 04:14:07.618 [consoleTerminate] got CTRL_C_EVENT, will terminate after current cmd ends
Sat Dec 21 04:14:07.618 [consoleTerminate] now exiting
Sat Dec 21 04:14:07.618 dbexit:
Sat Dec 21 04:14:07.618 [consoleTerminate] shutdown: going to close listening sockets...
Sat Dec 21 04:14:07.618 [consoleTerminate] closing listening socket: 536
Sat Dec 21 04:14:07.618 [consoleTerminate] shutdown: going to flush diaglog...
Sat Dec 21 04:14:07.618 [consoleTerminate] shutdown: going to close sockets...
Sat Dec 21 04:14:07.619 [consoleTerminate] shutdown: waiting for fs preallocator...
Sat Dec 21 04:14:07.619 [consoleTerminate] shutdown: lock for final commit...
Sat Dec 21 04:14:07.619 [consoleTerminate] shutdown: final commit...
Sat Dec 21 04:14:07.683 [consoleTerminate] shutdown: closing all files...
Sat Dec 21 04:14:07.684 [consoleTerminate] closeAllFiles() finished
Sat Dec 21 04:14:07.684 [consoleTerminate] journalCleanup...
Sat Dec 21 04:14:07.713 [consoleTerminate] removeJournalFiles
Sat Dec 21 04:14:07.772 [consoleTerminate] removeJournalFiles end
Sat Dec 21 04:14:07.772 [consoleTerminate] shutdown: removing fs lock...
Sat Dec 21 04:14:07.773 dbexit: really exiting now

131221  4:13:30 [Note] Plugin 'FEDERATED' is disabled.
131221  4:13:30 InnoDB: The InnoDB memory heap is disabled
131221  4:13:30 InnoDB: Mutexes and rw_locks use Windows interlocked functions
131221  4:13:30 InnoDB: Compressed tables use zlib 1.2.3
131221  4:13:30 InnoDB: Initializing buffer pool, size = 20.0M
131221  4:13:30 InnoDB: Completed initialization of buffer pool
131221  4:13:30 InnoDB: highest supported file format is Barracuda.
131221  4:13:31  InnoDB: Waiting for the background threads to start
131221  4:13:32 InnoDB: 5.5.35 started; log sequence number 50063556
131221  4:13:32 [Note] Server hostname (bind-address): '127.0.0.1'; port: 3306
131221  4:13:32 [Note]   - '127.0.0.1' resolves to '127.0.0.1';
131221  4:13:32 [Note] Server socket created on IP: '127.0.0.1'.
131221  4:13:32 [Note] Event Scheduler: Loaded 0 events
131221  4:13:32 [Note] C:\OpenServer\modules\database\MySQL-5.5.35\bin\mysqld.exe: ready for connections.
Version: '5.5.35-log'  socket: ''  port: 3306  MySQL Community Server (GPL)
131221  4:14:07 [Note] C:\OpenServer\modules\database\MySQL-5.5.35\bin\mysqld.exe: Normal shutdown

131221  4:14:07 [Note] Event Scheduler: Purging the queue. 0 events
131221  4:14:07  InnoDB: Starting shutdown...
131221  4:14:08  InnoDB: Shutdown completed; log sequence number 50063556
131221  4:14:08 [Note] C:\OpenServer\modules\database\MySQL-5.5.35\bin\mysqld.exe: Shutdown complete


Вайл профиля:
[main]
start=10
allow=1
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
mysql_driver="MySQL-5.5.35"
pg_driver=none
mongo_driver="MongoDB-2.4.8"
dbdriver1=1
dbdriver2=0
dbdriver3=1
http_log=1
mysql_log=1
postgresql_log=1
mongodb_log=1
dns_log=1
memcache_log=1
debugmail=1
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.2.17"
httpdriver="Apache-2.2.26"
memcachedriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=1
balloon=1
favorite=0
showswitch=1
debugmode=0
stext=0
sbrowser=0
email=0
vdisk=Z
selfhosts=0
webdir="domains"
browser=""
textred=""
filebrowser=""
sfilebrowser=0
memcache=0
dns=0
fzone=none
speed=0
maxrequests=0
upurl=http://open-server.ru/update/
durl=http://open-server.ru/download.html
folders="public_html www\htdocs www http htdocs docs web httpdocs public html site"

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""




Виндовс 8.1 Под Админом. Антивирус Авира. брандмауэра нет. С отключеным антивирусом также.
Другова ПК нет чтобы проверить.
Руководство пользователя прочитал от корки до корки, все пункты из раздела Решение проблем в руководстве выполнил!

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 21 дек 2013, 02:30

kost757, полагаю не выполняли Меню - Дополнительно - Первый запуск?

И где скриншоты черных окон? Вы нарушаете правила темы.

kost757
Сообщения: 11
C нами: 3 года 5 мес

Непрочитанное сообщение kost757 » 22 дек 2013, 00:25

Максим писал(а):kost757, полагаю не выполняли Меню - Дополнительно - Первый запуск?

И где скриншоты черных окон? Вы нарушаете правила темы.


1)Про окна забыл, извиняюсь. вот http://www.screencapture.ru/file/42B16027 забыл скрин приложить, хотя сделал.
2) это все яделал. тока непонятно зачем 2 раза ставить Visual++ если он встроен в систему? ну щас апять сделаю первый запуск. хотя при установке он был.

Добавлено спустя 3 минуты 50 секунд:
установил Visual/ все также.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 22 дек 2013, 00:37

kost757, полагаю тут два варианта:

1) Антивирус - он у вас с функцией брандмауэра и не дает Open Server доступа в сеть, или запускает его в некой песочнице. Настройте его.
2) Либо вы не удалили и не пересоздали файл hosts как того требует один из пунктов списка по решению проблем.

Судя по окнам отладки и предоставленным логам непосредственно с Open Server всё в порядке, он лишь не может проверить что запустился (возможные причины описал выше).

kost757
Сообщения: 11
C нами: 3 года 5 мес

Непрочитанное сообщение kost757 » 22 дек 2013, 04:39

Максим писал(а):kost757, полагаю тут два варианта:

1) Антивирус - он у вас с функцией брандмауэра и не дает Open Server доступа в сеть, или запускает его в некой песочнице. Настройте его.





2) Либо вы не удалили и не пересоздали файл hosts как того требует один из пунктов списка по решению проблем.

Судя по окнам отладки и предоставленным логам непосредственно с Open Server всё в порядке, он лишь не может проверить что запустился (возможные причины описал выше).


1)причом тут брандмауэр и php5.2 ? Опенсерв вообще должен запускатся и работать без интернета. в этом его смысл. host файл неудалял так как на других модулях он работает а 5.2 нет. host файл не удалял тк сами понимаете что он отвечает не за модуль 5.2 опенсервера а за другие вещи. с host проблем нет.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 22 дек 2013, 04:47

kost757 писал(а):1)причом тут брандмауэр и php5.2 ? Опенсерв вообще должен запускатся и работать без интернета. в этом его смысл. Кроме того на нем почта перестала отправлятся.(это все в новой версии неработают). не отправкой не сохранением писем в папку.


В своем сообщении я нигде не упоминал PHP 5.2, поскольку PHP действительно к проблеме незапуска сервера никакого отношения не имеет. Почему вы припрели сюда php не понятно.

Брандмауэр очень даже причем и не важно виндовый он или это антивирус с функцией брандмауэра. Если у Open Server нет прав на доступ к сетевым функциям, то он не сможет запуститься поскольку при запуске делается тестовое обращение к локальному домену http://домен/проверочный_файл. В Руководстве пользователя чётко указано, что если вы используете антививрус/брандмауэр их нужно настраивать.

Что касается интернета, то OpenServer-у он ни для запуска, ни для работы, не нужен. Вы зачем-то приплели сюда (к вашей проблеме) еще и интернет, помимо php. Зачем, почему, не понятно...

kost757
Сообщения: 11
C нами: 3 года 5 мес

Непрочитанное сообщение kost757 » 22 дек 2013, 05:52

Максим,
У меня проблема с запуском сервера на модуле 5,2 поэтому я и говорю про 5.2.
Если запускается на 5,3 5,4 и др но не запукается на 5,2 то проблема не в антивирусе. и я писал что отключал его. Я не с России поэтому пишу с ошибками как могу. Извините.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 22 дек 2013, 06:14

kost757 писал(а):У меня проблема с запуском сервера на модуле 5,2 поэтому я и говорю про 5.2.


Если не запускается именно с PHP 5.2 то тут всё проще, переключитесь на Nginx и включите отладочный режим. Во время запуска черные окна PHP покажут вам в чем проблема, если будет не понятно пишите сюда со скриншотами.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: Google [Bot] и 0 гостей