Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Аватара пользователя
ulukay
Сообщения: 77
Зарегистрирован:
29 мар 2016, 14:02

Re: Не запускается Open Server

ulukay » 11 июл 2018, 16:21

Вот так не помогает?
fri
Сообщения: 1
Зарегистрирован:
16 июл 2018, 16:35

Re: Сервер не запускается? Пиши СЮДА!

fri » 16 июл 2018, 16:58

Система Windows 7 под администратором без фаервола.
Сначало пробовал запускать по умолчанию с php 5... - всё успешно запустилось!
НО мне нужен именно php 7, и он не запускается нивкакую, какие я только не подбирал настройки :(

httpd.exe при запуске выдаёт вот такое окно:
Изображение

содержимое файла main.log:
2018-07-16 16:38:26  --------------------------------------------
2018-07-16 16:38:26  Начало процедуры запуска сервера
2018-07-16 16:38:26  Обновление Hosts файла
2018-07-16 16:38:26  Обновление конфигурации MySQL-5.6-x64
2018-07-16 16:38:26  Обновление конфигурации Sendmail
2018-07-16 16:38:26  Обновление конфигурации PHP-7.1-x64
2018-07-16 16:38:26  Обновление конфигурации PHPMyAdmin
2018-07-16 16:38:26  Обновление конфигурации Apache-PHP-7.2-x64
2018-07-16 16:38:26  Запуск MySQL-5.6-x64
2018-07-16 16:38:26  Запуск Apache-PHP-7.2-x64
2018-07-16 16:38:26  Проверка состояния сервера
2018-07-16 16:39:01  Не удалось запустить Apache-PHP-7.2-x64
2018-07-16 16:39:01  Сбой запуска!
2018-07-16 16:39:01  --------------------------------------------
2018-07-16 16:39:01  Начало процедуры остановки сервера
2018-07-16 16:39:01  Остановка системных модулей
2018-07-16 16:39:03  Отключение виртуального диска
2018-07-16 16:39:03  Сервер успешно остановлен за 1,997 секунд!
содержимое файла userdata\profiles\default.ini
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=1
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-7.1-x64"
httpdriver="Apache-PHP-7.2-x64"
mysql_driver="MySQL-5.6-x64"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=0
favorite=0
showswitch=1
debugmode=0
stext=0
sbrowser=0
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser=""
textred=""
filebrowser=""
sfilebrowser=0
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""

Аватара пользователя
ulukay
Сообщения: 77
Зарегистрирован:
29 мар 2016, 14:02

Re: Сервер не запускается? Пиши СЮДА!

ulukay » 16 июл 2018, 17:19

В этом посте есть ссылка на сайт. Вам следует обратить внимание на пункты 3.2, 3.4, 3.8.
Аватара пользователя
efendi
Сообщения: 10
Зарегистрирован:
04 дек 2016, 21:13

Re: Не запускается Open Server

efendi » 16 июл 2018, 17:48

ulukay писал(а):
11 июл 2018, 16:21
Вот так не помогает?
Помогло следующее:
В папке с Open Server правый клик по Open Server x64.exe > Свойства > Совместимость установить галочку в чекбоксе > Выполнять эту программу от имени администратора.
Аватара пользователя
ulukay
Сообщения: 77
Зарегистрирован:
29 мар 2016, 14:02

Re: Сервер не запускается? Пиши СЮДА!

ulukay » 16 июл 2018, 18:06

Ии.. правильно! А вот если бы-вы послушали совет автора в том посте я про - /modules/system/setup-0.bat (от имени администратора) вам-бы не пришлось потом запускатся от админа (что к стате чревато) да и ещё получили бы несколько полезных "плюшек" в добавок, описание которых есть в мануале.
Аватара пользователя
nastya96
Сообщения: 2
Зарегистрирован:
16 июл 2018, 18:29

Re: Сервер не запускается? Пиши СЮДА!

nastya96 » 16 июл 2018, 18:51

Уважаемые программисты и разработчики очень прошу помочь мне в огромной проблемы не могу понять как исправить уже даже с бубном вокруг компа хожу и шаманю все голову сломала. Выдает ошибку ( Warning: Unknown: Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini. in Unknown on line 0
phpMyAdmin - Error
Error during session start; please check your PHP and/or webserver log file and configure your PHP installation properly. Also ensure that cookies are enabled in your browser.

session_start(): Cannot send session cookie - headers already sent

session_start(): Cannot send session cache limiter - headers already sent

Cannot modify header information - headers already sent)
когда пытаюсь зайти в базе данных в определенный раздел но раньше все Ок было. Может кто то знает как мне помочь?? Очень благодарна буду.
Вложения
скрин.png
Аватара пользователя
efendi
Сообщения: 10
Зарегистрирован:
04 дек 2016, 21:13

Re: Сервер не запускается? Пиши СЮДА!

efendi » 16 июл 2018, 19:13

ulukay писал(а):
16 июл 2018, 18:06
Ии.. правильно! А вот если бы-вы послушали совет автора в том посте я про - /modules/system/setup-0.bat (от имени администратора) вам-бы не пришлось потом запускатся от админа (что к стате чревато) да и ещё получили бы несколько полезных "плюшек" в добавок, описание которых есть в мануале.
Напугало "чревато". Сделал как вы советовали. Сработало, большое спасибо :)
Аватара пользователя
ulukay
Сообщения: 77
Зарегистрирован:
29 мар 2016, 14:02

Re: Сервер не запускается? Пиши СЮДА!

ulukay » 16 июл 2018, 19:47

nastya96,
В файле конфигурации своей версии php найдите строку max_input_vars = 1000 она закомментирована(если вы её ещё не правили) раскомментируйте и увеличьте значение, думаю 10000 должно хватить.
Если сложно, второй вариант - добавить строку php_value max_input_vars 10000 в файл .htaccess
Аватара пользователя
nastya96
Сообщения: 2
Зарегистрирован:
16 июл 2018, 18:29

Re: Сервер не запускается? Пиши СЮДА!

nastya96 » 16 июл 2018, 20:53

Не помогло max_input_vars = 1000 ошибка все равно стоит может кто нибудь через тайм вивер поможет? Пожалуйста
Вложения
скрин.png
TokFronar
Сообщения: 9
Зарегистрирован:
14 июл 2018, 20:10

Re: Сервер не запускается? Пиши СЮДА!

TokFronar » 17 июл 2018, 01:51

nastya96 писал(а):
16 июл 2018, 18:51
когда пытаюсь зайти в базе данных в определенный раздел но раньше все Ок было. Может кто то знает как мне помочь?
Алгоритм такой же как и с Виндовс - если "раньше всё было Ок" - тогда нужно из бекапа восстановить всю базу (или только этот раздел).
Ответить