Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 546 236 раз!

Форум

Добро пожаловать, Гость!

Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
nsight
Сообщения: 7
C нами: 12 дней 2 часа

Непрочитанное сообщение nsight » 11 апр 2018, 17:01

Привет! Не могу запустить сервер. Машинка - Acer Aspire D150. Ос win xp sp3.
Поставил пакет премиум версии 5_2_8
Так как система 32битная - не всё настройки доступны. Часть серверов заявлена к использованию на системах Win7 и новее - их я даже не пробовал. Но часть не имеет такой пометки и, к сожалению, тоже не заводится. Например Apache 2.2 или Apache-PHP7. Единственно, чем удается добиться зеленого флажка это сервера типа Apache-PHP-Nginx1.12
,но увы запрос localhost/ выдает 504 Gateway Time-out от nginx (((

Смотрю логи :
2018/04/11 16:53:29 [error] 2208#4044: *1 upstream timed out (10060: Попытка установить соединение была безуспешной, т.к. от другого компьютера за требуемое время не получен нужный отклик, или было разорвано уже установленное соединение из-за неверного отклика уже подключенного компьютера) while connecting to upstream, client: 127.0.0.1, server: localhost, request: "GET / HTTP/1.1", upstream: "http://127.0.0.1:8080/", host: "localhost"

Запуск серверов в отладочном режиме выводит ошибку, что приложение httpd.exe не является win32 совместимым, что наводит на грустные мысли. (ведь запускаю я именно версию Open Server x86.exe)

Модуль PHP-7.0 и Мускуль-5.6 ошибок при старте не вызывают и меня полностью устраивают.

Как запустить апач под архитектуру x86?

вот скрин
Изображение

Аватара пользователя
Максим
Сообщения: 5335
C нами: 7 лет 4 мес
Контакты:

Непрочитанное сообщение Максим » 11 апр 2018, 18:02

nsight, выполните установку библиотек согласно процедуры первого запуска, как описано в руководстве. И покажите контрольные суммы вашего файла httpd.exe, сравню с оригиналом.

nsight
Сообщения: 7
C нами: 12 дней 2 часа

Непрочитанное сообщение nsight » 11 апр 2018, 18:33

Максим писал(а):nsight, выполните установку библиотек согласно процедуры первого запуска, как описано в руководстве. И покажите контрольные суммы вашего файла httpd.exe, сравню с оригиналом.


Процедура "первого запуска" ранее не выполнялась, благодарю. Она не быстро , но выполняется.
Данные контрольной суммы C:\OSPanel\modules\http\Apache-PHP-7+Nginx-1.12\httpd.exe
Такие:
; Generated by WIN-SFV32 v1.0
; (Compatible: Total Commander 7.03)
httpd.exe 895E178D

nsight
Сообщения: 7
C нами: 12 дней 2 часа

Непрочитанное сообщение nsight » 11 апр 2018, 19:02

Максим писал(а):nsight, выполните установку библиотек согласно процедуры первого запуска, как описано в руководстве. И покажите контрольные суммы вашего файла httpd.exe, сравню с оригиналом.

увы.
установка пакетов не помогла. проверял после перезагрузки.
вот скрин пакетов
https://www.screencast.com/t/y4ZOBo4mX3
httpd.exe 895E178D

Аватара пользователя
Максим
Сообщения: 5335
C нами: 7 лет 4 мес
Контакты:

Непрочитанное сообщение Максим » 11 апр 2018, 20:42

nsight, не не не, вам вот это нужно для контрольных сумм: https://ospanel.io/files/hashtab_v5.1.0.23_setup.zip

nsight
Сообщения: 7
C нами: 12 дней 2 часа

Непрочитанное сообщение nsight » 11 апр 2018, 21:15

Максим писал(а):nsight, не не не, вам вот это нужно для контрольных сумм: https://ospanel.io/files/hashtab_v5.1.0.23_setup.zip

https://www.screencast.com/t/PGqcMlvsgR
или
CRC32: 895E178D
MD5: 59748F5C1120B27B5305D00D464DF8F7
SHA-1: EB75193ABC5B427CA8FB344B87E1B160DC6CBF8D

Аватара пользователя
Максим
Сообщения: 5335
C нами: 7 лет 4 мес
Контакты:

Непрочитанное сообщение Максим » 11 апр 2018, 21:27

nsight, вроде как всё верно. Если у вас есть возможность, то скиньте в личку данные доступа к тимвьюверу, тогда смогу посмотреть лично.

nsight
Сообщения: 7
C нами: 12 дней 2 часа

Непрочитанное сообщение nsight » 11 апр 2018, 21:36

Максим писал(а):nsight, вроде как всё верно. Если у вас есть возможность, то скиньте в личку данные доступа к тимвьюверу, тогда смогу посмотреть лично.

Минут через 20 напишу данные Teamviewer-a . Его надо установить )

Аватара пользователя
Максим
Сообщения: 5335
C нами: 7 лет 4 мес
Контакты:

Непрочитанное сообщение Максим » 11 апр 2018, 22:06

nsight, спасибо, проблему вижу, но она явно в системе. Скорее всего апач версии 2.4 и выше просто не поддерживает XP. Сейчас погуглю и отпишусь вам как и что.

UPD. В общем посмотрел что там и как, потому что не помню. Уж слишком давно Open Server не поддерживает XP. Всё просто, php 5.5 и выше не поддерживают XP, соответственно я даже встроил в программу ограничение на этот счёт, для PHP 7 просто нет этого предупреждения, вот вы и пытались запустить то, что априори под XP не запускается.

Советую обновиться до windows 7 sp1 и забыть XP как страшный сон. XP официально не поддерживается и опенсервер можно использовать там только для запуска совсем старых версий PHP в целях некрофилии.

nsight
Сообщения: 7
C нами: 12 дней 2 часа

Непрочитанное сообщение nsight » 11 апр 2018, 22:30

Максим писал(а):nsight, спасибо, проблему вижу, но она явно в системе. Скорее всего апач версии 2.4 и выше просто не поддерживает XP. Сейчас погуглю и отпишусь вам как и что.

Премного благодарю!
UPD.
Резюме понятно.
Не смотря на то, что ничего не получилось очень тронут вашим вниманием к пользователям. Мне нравится OpenServer и я использую его на другой рабочей машине с архитектурой x64. Хотел использовать и на резервном компе - но видимо увы - Win7 с 1Гб оперативки будет тяжело жить. Я повелся на системные требования на главной странице сайта. Возможно их следует привести в соответствие с реалиями.
еще раз спасибо.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 3 гостя