Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 143 раза!

Форум

Добро пожаловать, Гость!

Симлинки в папке для доменов игнорируются

Обсуждение проблем в работе программного комплекса
agentasg
Сообщения: 2
C нами: 3 года 10 мес

Непрочитанное сообщение agentasg » 12 янв 2013, 15:53

В файле \userdata\config\имя_сервера.conf меняем параметр и симлинки заработают:

<Directory />
    Options None   -->   Options FollowSymLinks
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>


Надеюсь, поможет.

makanaki
Сообщения: 4
C нами: 3 года 10 мес

Непрочитанное сообщение makanaki » 12 янв 2013, 19:50

Симлинки обычные, никаких проблем с ними в любых других приложениях нет. Но симлинки, находящиеся в папке "domains" видятся и распознаются, как домены, но при попытке доступа к такому домену, получаешь 403. Могу вам, тесткейс, что-ли, сделать, если хотите.
Так или иначе, это, очевидно, - бага, и раз уж вы свою сборку позиционируете как удобное приложение именно под windows, то этим стоило бы заняться.
А так, пришлось перенести папки физически в папку "domains".

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 12 янв 2013, 19:53

makanaki писал(а):Симлинки обычные, никаких проблем с ними в любых других приложениях нет. Но симлинки, находящиеся в папке "domains" видятся и распознаются, как домены, но при попытке доступа к такому домену, получаешь 403. Могу вам, тесткейс, что-ли, сделать, если хотите.
Так или иначе, это, очевидно, - бага, и раз уж вы свою сборку позиционируете как удобное приложение именно под windows, то этим стоило бы заняться.
А так, пришлось перенести папки физически в папку "domains".


Какое отношения имеет работа сервера Apache к программе Open Server и уж тем более к тому как я позиционирую программу? Никакого, это сервер вам ошибку выдаёт, а не программа. Это не бага, а просто вариант конфигурации, а конфигурация заметье - в вашей власти. Как исправить вам написали выше, в последней версии сделал такой конфиг Apache изначальным. Хотите сказать что это исправление не помогает?

makanaki
Сообщения: 4
C нами: 3 года 10 мес

Непрочитанное сообщение makanaki » 12 янв 2013, 19:56

agentasg писал(а):В файле \userdata\config\имя_сервера.conf меняем параметр и симлинки заработают:

<Directory />
    Options None   -->   Options FollowSymLinks
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>


Надеюсь, поможет.


Спасибо большое, действительно помогло.

Добавлено спустя 1 минуту 35 секунд:
Как исправить вам написали выше, в последней версии сделал такой конфиг Apache изначальным. Хотите сказать что это исправление не помогает?

Ну что ж вы так лично все воспринимаете. Должно исправить, судя по всему. Спасибо за то, что уделили этому внимание.

Аватара пользователя
Максим
Сообщения: 4868
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 12 янв 2013, 20:05

makanaki писал(а):Ну что ж вы так лично все воспринимаете. Должно исправить, судя по всему. Спасибо за то, что уделили этому внимание.


Настройка конфигурации веб-сервера "под себя" - это забота пользователя, т.е. вас. Но ругались вы не на себя, а на меня, почему-то. Вот в новой версии изменил конфиг конфигурации как посоветовали выше, надеюсь больше претензий ко мне нет. Приятной работы!


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя