Mcrypt+Laravel4.2

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
dolben
Сообщения: 4
Зарегистрирован:
02 ноя 2017, 00:10

Mcrypt+Laravel4.2

dolben » 03 июн 2018, 13:45

требует mcrypt лара. пробовал 5.6 и 7.2 пхп сборки. ругается. почитал ветки форума. старые посты есть что прям в сборке все есть. /ext внимательно изучал не нашел. Глаза балуются или что-то изменилось? Пожалуйста помоги установить это расширение.
Tatyana_Kazakova
Сообщения: 4
Зарегистрирован:
20 сен 2018, 12:06

Re: Mcrypt

Tatyana_Kazakova » 06 окт 2018, 20:11

Добрый день, помогите чайнику, устанавливала Opencart англоязычный на Openserver, всё установилось без проблем, заработало. Сейчас хочу установить русифицированный ocStore, скачала, но при установке ругается, что нету mCrypt, как так? Англоязычная же нормально установилась, по всем требованиям сервак подходил. Помогите, пожалуйста.
Аватара пользователя
Ink0gnit0
Сообщения: 112
Зарегистрирован:
17 мар 2013, 21:16

Re: Mcrypt+Laravel4.2

Ink0gnit0 » 06 окт 2018, 22:44

Tatyana_Kazakova,
Используйте модули Apache 2.4 + PHP5.x/PHP7.0/PHP7.1.
C версии PHP 7.2, mcrypt уже считается устаревшим: http://php.net/manual/ru/migration71.deprecated.php
SagePtr
Сообщения: 24
Зарегистрирован:
27 сен 2016, 01:10

Re: Mcrypt+Laravel4.2

SagePtr » 07 окт 2018, 17:17

dolben писал(а):
03 июн 2018, 13:45
требует mcrypt лара
Рили? mcrypt очень давно устарел и был выкинут из PHP. Вангую, у вас версия Laravel какая-то очень древняя
Ответить