Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 713 раз!

Форум

Добро пожаловать, Гость!

Не работет метод POST

Обсуждение вопросов на другие темы связанные с веб-разработкой
volunteer
Сообщения: 4
C нами: 4 года 8 мес

Непрочитанное сообщение volunteer » 24 мар 2012, 22:06

не работает метод PHP POST хотя метод GET работает думаю где ошибка настройки или PHP или Apache.
Подскажите где это настроить ато капец будет.
С уважением начинающий програмист PHP.

Аватара пользователя
duxabilii
Сообщения: 216
C нами: 5 лет 5 мес
Контакты:

Непрочитанное сообщение duxabilii » 25 мар 2012, 03:43

А более подробно, с примерами кода, который не работает???

Bueno
Сообщения: 83
C нами: 4 года 10 мес

Непрочитанное сообщение Bueno » 25 мар 2012, 18:34

а как вы выяснили, что не работает?..

volunteer
Сообщения: 4
C нами: 4 года 8 мес

Непрочитанное сообщение volunteer » 25 мар 2012, 21:22

не передаются в метод значения переменных

volunteer
Сообщения: 4
C нами: 4 года 8 мес

Непрочитанное сообщение volunteer » 26 мар 2012, 00:10

а выяснил просто metod="GET" работает а ставлю metod-"POST" не работает

Аватара пользователя
duxabilii
Сообщения: 216
C нами: 5 лет 5 мес
Контакты:

Непрочитанное сообщение duxabilii » 26 мар 2012, 06:57

volunteer писал(а):а выяснил просто metod="GET" работает а ставлю metod-"POST" не работает

а если попробовать method="post"

Bueno
Сообщения: 83
C нами: 4 года 10 мес

Непрочитанное сообщение Bueno » 26 мар 2012, 08:30

duxabilii писал(а):
volunteer писал(а):а выяснил просто metod="GET" работает а ставлю metod-"POST" не работает

а если попробовать method="post"

совершенно верно.. по умолчанию форма передается методом get.. т.к. тег написан не правильно и браузером не распознан, им и передается..

volunteer
Сообщения: 4
C нами: 4 года 8 мес

Непрочитанное сообщение volunteer » 26 мар 2012, 09:04

Bueno писал(а):
duxabilii писал(а):
volunteer писал(а):а выяснил просто metod="GET" работает а ставлю metod-"POST" не работает

а если попробовать method="post"

совершенно верно.. по умолчанию форма передается методом get.. т.к. тег написан не правильно и браузером не распознан, им и передается..

Именно так!!! спасибо. все получилось. исправил синтаксис. ПОКАТИЛО
СПАСИБО ВАМ ВСЕМ за ПОМОЩь!!!!!


Вернуться в «Оффтоп и другие темы»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость