Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 435 897 раз!

Форум

Добро пожаловать, Гость!

Не запускается PhpMyAdmin

Обсуждение проблем в работе программного комплекса
Pashik
Сообщения: 95
C нами: 11 мес 19 дней

Непрочитанное сообщение Pashik » 29 июн 2017, 13:35

novichok, здесь явной агрессии не наблюдается. На главной странице этого сайта указана основная информация. Если вы ее не заметили, и не сразу поняли, что сервер ее и настраивается, то мне вас жаль :)

Langobard
Сообщения: 4
C нами: 6 мес 20 дней

Непрочитанное сообщение Langobard » 29 июн 2017, 21:17

Pashik писал(а):Langobard, а как ваше сообщение относится к теме форума? "Не запускается PhpMyAdmin". Что касаемо модулей сервера - они все работают прекрасно, включая 5.3.

Да очень просто соотносится:

Мне Обязательно нужен php 5.3.

ДАНО: Если я включаю php 5.3 ,то у меня не запускается PhpMyAdmin.
ПРИМЕЧАНИЕ: В древнем Denwer всё прекрасно работает (PhpMyAdmin вместе с php 5.3)

ВОПРОС: Как запустить PhpMyAdmin вместе с php 5.3 ?

Ну уж не знаю как проще сформулировать...

Аватара пользователя
Максим
Cейчас: в сети
Сообщения: 5254
C нами: 7 лет 1 мес
Контакты:

Непрочитанное сообщение Максим » 29 июн 2017, 21:24

Langobard, вы не умеете читать или тупо лень? На предыдущей странице уже дан ответ на этот вопрос: современный PHPMyAdmin не совместим с PHP 5.3. Если лично вам нужно, возьмите и установите вместо стандартной версии PHPmyAdmin какую-нибудь старую, которая поддерживает php 5.3 и будет вам счастье.

Pashik
Сообщения: 95
C нами: 11 мес 19 дней

Непрочитанное сообщение Pashik » 30 июн 2017, 04:13

Langobard, немного не в тему.. что такого имеется в 5.3, чего нельзя найти в 7.0? Раз уж вам обязательно нужен 5.3. Уже любой (уважающий себя) хостинг имеет поддержку седьмой версии PHP.

Langobard
Сообщения: 4
C нами: 6 мес 20 дней

Непрочитанное сообщение Langobard » 30 июн 2017, 08:11

Pashik писал(а):Langobard, немного не в тему.. что такого имеется в 5.3, чего нельзя найти в 7.0? Раз уж вам обязательно нужен 5.3. Уже любой (уважающий себя) хостинг имеет поддержку седьмой версии PHP.

Спасибо за то, что пишете, не брызгая слюной на экран в адрес новичков.
(прикольно - енот слюной не брызжет, а клон человека так пеной изошёлся :) ).

Цитата из моего первого сообщения:
Сайт писал другой разработчик и возникла проблема с переносом его на новый хостинг с php 5.5.


Мне нужен php 5.3 потому, что сайт не работает на php 5.5.

eandr-67
Сообщения: 56
C нами: 2 года 11 мес

Непрочитанное сообщение eandr-67 » 30 июн 2017, 09:44

Pashik писал(а):Langobardчто такого имеется в 5.3, чего нельзя найти в 7.0?

Каждый новый выпуск PHP - это удаление устаревших конструкций. Потому если проект начали создавать много лет назад, то там гарантированно будут использованы вещи, отсутствующие в современных версиях PHP.

Например, у меня на работе минимум половина классов имеет нотацию PHP 4. Потому перейти на что-то более свежее, чем PHP 5.3 (а это последняя версия, совместимая с четвёркой), - это переписывать код нескольких тысяч файлов.

Pashik
Сообщения: 95
C нами: 11 мес 19 дней

Непрочитанное сообщение Pashik » 30 июн 2017, 09:47

Langobard, тогда нужно сменить версию phpMyadmin на более древнюю, как уже советовали выше. Как сменить версию, я не знаю. Уже создавал тему на этом форуме, без результатов. Я бы на вашем месте попробовал скачать другую версию Open Server, например, 5.2.2. Я начинал с нее, когда она была актуальна. Работал тогда на версии PHP 5.3, и phpMyAdmin также работал без проблем. Я поискал на просторах интернета, откуда можно без проблем скачать. И вот вам прямая ссылка на базовую версию: скачать (108 МБ). Если не нужны программки, и только самые необходимые модули (Apache, Nginx, PHP, MySQL), то идеально подойдет. На полную версию ссылка здесь: скачать (504 МБ).
Последний раз редактировалось Pashik 30 июн 2017, 09:50, всего редактировалось 1 раз.

Pashik
Сообщения: 95
C нами: 11 мес 19 дней

Непрочитанное сообщение Pashik » 30 июн 2017, 09:48

eandr-67, да, вы правы. Я в тот момент об этом не подумал. У меня никогда не было крупных проектов, да и при переходе на новые версии проблем особых не вызывало. Потому мне это и не знакомо :)

Ink0gnit0
Сообщения: 73
C нами: 4 года 10 мес

Непрочитанное сообщение Ink0gnit0 » 30 июн 2017, 10:29

Langobard,
1. Создайте в каталоге доменов (C:\openserver\domains) каталог pma
2. Скачайте и распакуйте в созданный каталог устаревшую версию phpmyadmin - phpMyAdmin-4.0.10.20-all-languages.zip
3. Переименуйте файл C:\openserver\domains\pma\config.sample.inc.php в C:\openserver\domains\pma\config.inc.php
4. Если у вас пользователь root без пароля и вы намерены от его имени заходить в phpmyadmin, откройте в блокноте файл C:\openserver\domains\pma\config.inc.php и измените параметр:
$cfg['Servers'][$i]['AllowNoPassword'] = true;

5. Перезапустите OSPanel, если был запущен. Проверьте результат: http://pma/

Ink0gnit0
Сообщения: 73
C нами: 4 года 10 мес

Непрочитанное сообщение Ink0gnit0 » 30 июн 2017, 11:02

Langobard,
Есть и другой вариант:
1. Создайте каталог C:\openserver\modules\system\html\openserver\phpmyadmin\legacy
2. Скачайте и распакуйте в созданный каталог устаревшую версию phpmyadmin - phpMyAdmin-4.0.10.20-all-languages.zip
3. Скопируйте конфигурационный файл C:\openserver\modules\system\html\openserver\phpmyadmin\config.inc.php в C:\openserver\modules\system\html\openserver\phpmyadmin\legacy\config.inc.php
4. Откройте в блокноте файл C:\openserver\modules\system\html\openserver\phpmyadmin\index.php и измените:
<?php
/* vim: set expandtab sw=4 ts=4 sts=4: */
...........

на следующее
<?php
if (version_compare(phpversion(), '5.5.0', '<')) {
   header('Location: legacy/');
}
/* vim: set expandtab sw=4 ts=4 sts=4: */
...................

5. Запустите PhpMyAdmin контекстное меню в системном трее. Проверьте результат для различных версии PHP.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей