Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 022 697 раз!

Форум

Добро пожаловать, Гость!

Подготовка версии 4.1.1: список

Обсуждение общих вопросов связанных с программой
Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 01 мар 2012, 21:40

Wave писал(а):Меня больше интересует Ruby. Я правильно понял, что в 4.2.8 его не будет?
(Заодно слегка любопытно, почему именно такой номер версии?)

Его в Open Server не будет вообще. Ни сейчас, ни в будущем. Увы.

Номер версии - это номер собственно ветки + номер месяца (2ой месяц это февраль) + номер релиза в этом месяце. Хотя в феврале выпустить 4.2.8 не получилось :mrgreen: Слишком много изменений я решил сделать, не подрассчитал :ugeek:

Ramix
Сообщения: 14
C нами: 4 года 10 мес

Непрочитанное сообщение Ramix » 02 мар 2012, 01:47

В новой версии будет обновлен PHP до релизного 5.4?

fuckyea
Сообщения: 3
C нами: 5 лет 2 мес

Непрочитанное сообщение fuckyea » 02 мар 2012, 10:02

Ramix писал(а):В новой версии будет обновлен PHP до релизного 5.4?

Присоединяюсь к вопросу.

Ganster41
Сообщения: 66
C нами: 4 года 9 мес

Непрочитанное сообщение Ganster41 » 02 мар 2012, 12:23

Эх, сделали бы еще скрипты запуска/остановки компонентов редактируемыми, было бы круто)

pomo4ka
Сообщения: 43
C нами: 4 года 10 мес

Непрочитанное сообщение pomo4ka » 02 мар 2012, 20:07

PHP 5.4.0 - точно должен быть в новой версии. :)

Wave
Сообщения: 39
C нами: 4 года 9 мес

Непрочитанное сообщение Wave » 02 мар 2012, 21:03

Максим писал(а):
Wave писал(а):Меня больше интересует Ruby. Я правильно понял, что в 4.2.8 его не будет?
Его в Open Server не будет вообще. Ни сейчас, ни в будущем. Увы.
Можно узнать причины? Помнится, в первоначальных планах он был.

P.s. Имхо, если php 5.4, то 5.3 и 5.2 всё равно нужны оба-два.

Аватара пользователя
Максим
Сообщения: 4878
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 02 мар 2012, 22:12

Wave писал(а):
Максим писал(а):
Wave писал(а):Меня больше интересует Ruby. Я правильно понял, что в 4.2.8 его не будет?
Его в Open Server не будет вообще. Ни сейчас, ни в будущем. Увы.
Можно узнать причины? Помнится, в первоначальных планах он был.

P.s. Имхо, если php 5.4, то 5.3 и 5.2 всё равно нужны оба-два.

Причины просты - малой по размеру и полностью портативной версии Ruby не существует. Во всяком случае я не нашел. Найдёте - подскажите. И в планах его не было, вы заблуждаетесь. Ruby был лишь в списке предложений пользователей Open Server, но не более. Я рассмотрел это предложение и удалил из списка ввиду невозможности реализации.

norgen
Сообщения: 10
C нами: 4 года 9 мес

Непрочитанное сообщение norgen » 04 мар 2012, 21:53

Предлагаю добавить возможность выбора сайта, который будет открываться извне, т.е. при открытии сайта по внешнему ip адресу. Иначе, чтоб продемонстрировать заказчику что-то приходится мудрить с конфигами.
Спасибо за сервер.

norgen
Сообщения: 10
C нами: 4 года 9 мес

Непрочитанное сообщение norgen » 05 мар 2012, 00:49

Можно ввести режим "одиночного" сервера (не знаю как это можно более правильно выразить) и режим виртуальных серверов. В "одиночном" на localhost будет только один выбранный сайт, он-же будет доступен извне. В режиме виртуальных серверов - все как обычно.

Так-же было бы не плохо в режиме "одиночного" сервера биндить внешний ip и кликом по какому-либо пункту меню или просто по значку в трее копировать его в буфер обмена как ссылку, чтоб предоставить ее кому-либо (заказчику).

Как появятся лишние деньги - обязательно подкину в поддержку. Весьма полезный весч получается)) Спасибо.

Dune
Сообщения: 1
C нами: 4 года 9 мес

Непрочитанное сообщение Dune » 05 мар 2012, 14:22

php 5.4 очень интересен.
Как выйдет версия с нужным пхп сразу же закину денежек на счет.


Вернуться в «Обсуждение Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 2 гостя