Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 020 090 раз!

Форум

Добро пожаловать, Гость!

Опечатка в стандартном конфиге PHP 5.6

Обсуждение проблем в работе программного комплекса
Xandros
Сообщения: 2
C нами: 2 года 6 мес

Непрочитанное сообщение Xandros » 27 янв 2016, 16:44

Нашел опечатку в коде. После исправления php скрипты стали работать правильно:
%disallow%open_basedir = "%ssitedir%;%sprogdir%/userdata/temp;%sprogdir%/modules/system/html/openserver;%sprogdir%/modules/php/%phpdriver%"


Исправил на:
%disallow%open_basedir = "%sitedir%;%sprogdir%/userdata/temp;%sprogdir%/modules/system/html/openserver;%sprogdir%/modules/php/%phpdriver%"


Тестировалось на конфигурации Nginx 1.9 + PHP 5.6 + MySQL 5.6
P.S> Ничего не правил - только недавно обновил.

Аватара пользователя
Максим
Сообщения: 4874
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 27 янв 2016, 17:57

Хорошо что ваши скрипты заработали правильно. Опечаток и ошибок в шаблоне конфига PHP нет. Вы заменили один путь на точно такой же, но с обратным слешем, оба пути в PHP под Windows являются верными. Проблема ваших скриптов - это не проблема конфигурации PHP в Open Server.

vlad_luxor
Сообщения: 45
C нами: 2 года 5 мес

Непрочитанное сообщение vlad_luxor » 27 янв 2016, 18:27

Хм.. А ведь разница в путях вот какая: "%ssitedir%" -> "%sitedir%". Это опечатка или я ошибаюсь?

Аватара пользователя
Максим
Сообщения: 4874
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 27 янв 2016, 21:49

vlad_luxor, Вы ошибаетесь. Это не опечатка.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость