Проблема с запуском сервера

Обсуждение проблем в работе программного комплекса
mitris
Сообщения: 12
Зарегистрирован:
01 фев 2012, 20:46

Проблема с запуском сервера

mitris » 01 фев 2012, 20:52

Windows 7 x64. Брандмауэр отключен. Антивирус отключен. Запускаю ОпенСервер от имени администратора. "Первый запуск" сделал, все ок. В настройках Skype убрал галочку.
До этого стояли отдельно апач, рнр, мускул, постгресс все работало. Решил поставить ОпенСервер, предварительно все удалив. При запуске возникает ошибка. (в режиме отладки)
S:\server\http\Nginx-1.0.11>nginx.exe
nginx: [emerg] bind() to 127.0.0.5:443 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)

S:\server\http\Nginx-1.0.11>PAUSE
Для продолжения нажмите любую клавишу . . .
а в логах это
2012/02/01 19:43:40 [emerg] 2724#2220: bind() to 127.0.0.5:443 failed (10013: An attempt was made to access a socket in a way forbidden by its access permissions)
2012/02/01 19:43:57 [notice] 3876#2276: signal process started
2012/02/01 19:43:57 [error] 3876#2276: CreateFile() "S:/server/http/Nginx-1.0.11/logs/httpd.pid" failed (2: The system cannot find the file specified)
Тоже самое если апач выбран в конфигах. Сейчас в конфигах выбрал РНР 5.3.9, мускул и nginx.
Что можно сделать, что бы запустилось и можно было работать?
Аватара пользователя
Максим
Сообщения: 5414
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Проблема с запуском сервера

Максим » 01 фев 2012, 20:59

Ёлы палы, соседние темы почитайте. Ваш антивирус\фаервол не дает апачу занять ip:порт или пара ip:порт уже заняты другой программой.

Странно правда что Open Server не обнаружил кто занял порт, в логах должно быть отражено.

Смотрите через netstat -ano что там у вас занимает.
mitris
Сообщения: 12
Зарегистрирован:
01 фев 2012, 20:46

Re: Проблема с запуском сервера

mitris » 01 фев 2012, 21:01

Антивирус отключен, с консоли телнетом слушал порт все ок.
mitris
Сообщения: 12
Зарегистрирован:
01 фев 2012, 20:46

Re: Проблема с запуском сервера

mitris » 01 фев 2012, 21:02

Вот блин...Можете удалять тему. Моя ошибка была. Нужно было ребутнуть комп после удаления апача и всего прочего.
Ответить