Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 021 072 раза!

Форум

Добро пожаловать, Гость!

Ошибки при запуске сервера Apache 2.2 (http.exe)

Обсуждение проблем в работе программного комплекса
Аватара пользователя
Redee
Сообщения: 218
C нами: 3 года 5 мес

Непрочитанное сообщение Redee » 09 фев 2015, 21:02

ОС - WinXP SP3
Лог отладки веб-сервера >
[spoiler][Mon Feb 09 19:50:43 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:50:43 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:50:43 2015] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Feb 09 19:50:44 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:50:44 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:50:44 2015] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Feb 09 19:51:42 2015] [notice] Apache/2.2.29 (Win32) mod_ssl/2.2.29 OpenSSL/0.9.8zc configured -- resuming normal operations
[Mon Feb 09 19:51:42 2015] [notice] Server built: Sep 10 2014 11:58:36
[Mon Feb 09 19:51:42 2015] [notice] Parent: Created child process 2560
[Mon Feb 09 19:51:42 2015] [notice] Disabled use of AcceptEx() WinSock2 API
[Mon Feb 09 19:51:42 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:51:42 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:51:42 2015] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Feb 09 19:51:43 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:51:43 2015] [warn] RSA server certificate CommonName (CN) `openserver' does NOT match server name!?
[Mon Feb 09 19:51:43 2015] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Mon Feb 09 19:51:46 2015] [notice] Child 2560: Child process is running
[Mon Feb 09 19:51:46 2015] [notice] Child 2560: Acquired the start mutex.
[Mon Feb 09 19:51:46 2015] [notice] Child 2560: Starting 32 worker threads.
[Mon Feb 09 19:51:46 2015] [notice] Child 2560: Listening on port 443.
[Mon Feb 09 19:51:46 2015] [notice] Child 2560: Listening on port 80.[/spoiler]

[upd=1423505165][/upd]
Версия OpenServer 5.2.2

[upd=1423505337][/upd]
Сейчас протестирую на 5.2.0 версии.
На 4.9.0 точно все нормуль шло.
Вложения
2015-02-09_195158.jpg
2015-02-09_195140.jpg
2015-02-09_195130.jpg
2015-02-09_195118.jpg

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 09 фев 2015, 21:10

Конфликт с установленным в систему SVN. Отключите WinPath в настройках Open Server, а если не поможет, удалите SVN либо из системы либо расширение из конфига PHP (я так понимаю оно глючит).

Аватара пользователя
Redee
Сообщения: 218
C нами: 3 года 5 мес

Непрочитанное сообщение Redee » 09 фев 2015, 21:20

Свой path + WinPath помогло.
Сейчас проверю на чистом свой path > расширение PHP.

[upd=1423506861][/upd]
Или глаза "замылились", чето совсем не вижу где это в конфиге php.
e:\OpenServer\userdata\config\PHP-5.4_php.ini >>>

Собственно стоит TortoiseSVN.
Вот эти dll которые каким то чудесным образом спрашивает веб-сервер.

[upd=1423507572][/upd]
Но на 4.9.0. версии все как по маслу запускалось.
И TortoiseSVN у меня всегда стояла.
И да каталог TortoiseSVN добавлен в системные пути.

[upd=1423507870][/upd]
Попробуем стереть каталог из Win Path.
Посмотрим постучится ли туда или нет.

[upd=1423508053][/upd]
Странновато ведет себя - специально неправильно написал путь к папке тортойса в Path - ошибок Нет!
Хммм....

[upd=1423508100][/upd]
То есть как оно могло вгрузить эти DLL если путь НЕ правильный.

[upd=1423508249][/upd]
То есть понятно если я через Свой Path - то в определенной точке передается аля > ищу эти Длл.
Если с Win Path - то ищу другие Длл.
Во как. Возможно сильно ошибаюсь, но это логически если рассуждать.
Вложения
2015-02-09_203134.jpg

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 09 фев 2015, 22:00

Какое-то расширение подхватывает, либо подхватываются dll-ки от SSL не те.

Аватара пользователя
Redee
Сообщения: 218
C нами: 3 года 5 мес

Непрочитанное сообщение Redee » 09 фев 2015, 22:11

Отрубил openSSL - НЕ помогло.

[upd=1423509119][/upd]
Вопрос еще тут а точно ли следы ведут к конфигу Пхп...

[upd=1423509350][/upd]
Походу 1ое предположение было верно.
Попробовал с Php-5.2 ошибок НЕТ.

[upd=1423509372][/upd]
Надо теперь сравнить Php-5.2 и 5.4 где различия.

[upd=1423509842][/upd]
Php-5.3 тоже в ошибку улетает.
Значится - имеем следующее.
Какое то расширение пришло с версии 4.9.0+ которое было добавлено в Php-5.3 и Php-5.4, но НЕ добавлено в Php-5.2.

Может вспомните что именно ?
А то я запарюсь перебирать их в конфиге.

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 09 фев 2015, 22:31

Да как то не было необходимости проверять. Раньше в состав было включено php_svn.dll но его уже давно нет. Поэтому проверяйте вручную, отключая расширения поочередно. Попробуйте переключится на Nginx, не факт, но может покажет в каком расширении проблема. Проблема вообще может быть в Apache или SSL.

А лучше, как я уже сказал, просто не включайте WinPath.

Аватара пользователя
Redee
Сообщения: 218
C нами: 3 года 5 мес

Непрочитанное сообщение Redee » 09 фев 2015, 22:36

Я Win Path и НЕ включал никогда.
Лишь проверил и с ним также.

Вот различия в расширениях, которые появились новые в Php-5.4 относительно Php-5.2.
Будем щас поочередно проверять.
9 запусков OpS в итоге или меньше...
Спасибо за наводку на Nginx!!!

extension=php_enchant.dll
extension=php_fileinfo.dll
extension=php_igbinary.dll
extension=php_imagick.dll
extension=php_mongo.dll
extension=php_pdflib.dll
extension=php_redis.dll
extension=php_timezonedb.dll
extension=php_xmlrpc.dll

[upd=1423510784][/upd]
Ураааааааааааааа свинья зарыта была здесь!!! >>>
extension=php_mongo.dll

Ну и монго чтоб тебя...

[upd=1423510960][/upd]
Ага оно то и хорошо что нарыл - только если мне эта база данных понадобится, то придется только с винПатчем грузить брррррррррр.

Может пересоберете php_mongo.dll чтобы смотрела куда надо ???

Аватара пользователя
Максим
Сообщения: 4877
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 09 фев 2015, 22:57

Я беру с официального сайта, но раз такое дело то да, видимо придётся пересобирать теперь самому. Просто странно чего оно их вообще хочет, ведь если SVN не установлен, то оно и не ругается, работает.

Аватара пользователя
Asmodey
Сообщения: 299
C нами: 4 года 7 мес

Непрочитанное сообщение Asmodey » 10 фев 2015, 10:44

Я ему подкладываю длл и он(апачи) унимается. Монгой не пользуюсь.

yurik3zzz
Сообщения: 1
C нами: 1 год 9 мес

Непрочитанное сообщение yurik3zzz » 17 фев 2015, 20:06

Та же самая проблема.
Решилась копированием библиотек из c:\Program Files\TortoiseSVN\bin\
в d:\OpenServer\modules\http\Apache-2.4\bin\
libsvn_tsvn32.dll
libsasl32.dll
libaprutil_tsvn32.dll
libapr_tsvn32.dll
intl3_tsvn32.dll


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость