Обсуждение Open Server 5.2

Обсуждение общих вопросов связанных с программой
yuran
Сообщения: 10
Зарегистрирован:
03 мар 2012, 01:34
Откуда: Россия
Контактная информация:

yuran » 08 дек 2014, 21:08

Ребята дайте пожалуйста кто нибудь скачать предыдущую версию. Поторопился снести, а в новой выдает ошибку при установке скрипта:
( ! ) InvalidArgumentException: Given expression is not a regex. in C:\OpenServer\domains\crea\vendor\symfony\finder\Symfony\Component\Finder\Expression\Regex.php on line 77
Главное в предыдущей все нормально устанавливалось... Может конечно не настроено что то или расширение какое нибудь не включено. В общем хочется поработать до выхода фиксов новой версии. Можно где то найти предыдущую версию? Спасибо.
Аватара пользователя
Максим
Сообщения: 5365
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 08 дек 2014, 21:18

yuran, так на 5-ой странице же написали решение, 1 строку удалить нужно. Для вас это настолько сложно, что вы готовы качать старую версию? Завтра так вообще еще одна новая выйдет.
Den314
Сообщения: 5
Зарегистрирован:
02 окт 2014, 18:31

Den314 » 08 дек 2014, 21:25

Доброй ночи!
Подскажите когда будет обновление phpmyadmin в OpenServer? уже доступна для скачивания pma 4.3.0, а у вас в проекте 4.0.10.6...
Аватара пользователя
Oops
Сообщения: 48
Зарегистрирован:
08 дек 2014, 21:25
Откуда: Краснодар
Контактная информация:

Oops » 08 дек 2014, 21:28

Привет!
У меня вопрос по настройке nginx
Никак не могу понять где его настроить, собственно мне нужно настроить location
Спасибо.
Аватара пользователя
Максим
Сообщения: 5365
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 08 дек 2014, 21:42

Den314 писал(а):Доброй ночи!
Подскажите когда будет обновление phpmyadmin в OpenServer? уже доступна для скачивания pma 4.3.0, а у вас в проекте 4.0.10.6...
Его пока что не будет, 4.3 это другая ветка, а не новая версия. В Open Server используется старая ветка phpmyadmin из-за наличия php старой версии 5.2.

Вот отомрёт php 5.2 через пару лет окончательно, тогда и удалю его из сборки и phpmyadmin можно будет обновить.
yuran
Сообщения: 10
Зарегистрирован:
03 мар 2012, 01:34
Откуда: Россия
Контактная информация:

yuran » 08 дек 2014, 22:01

Максим писал(а):yuran, так на 5-ой странице же написали решение, 1 строку удалить нужно. Для вас это настолько сложно, что вы готовы качать старую версию? Завтра так вообще еще одна новая выйдет.
Спасибо огромное! Действительно все заработало... Подумал, что не в этой строке дело. Остаюсь на этой версии и жду обновления. Еще раз спасибо большое!
Аватара пользователя
hudson
Сообщения: 50
Зарегистрирован:
30 май 2012, 19:25

hudson » 09 дек 2014, 15:41

Несколько ошибочек по конфигурации "Apache-2.2+Nginx-1.6" в 5.2.0

- В конфигурации есть загрузка модуля rpaf_module, но modules/mod_rpaf.so отсутствует (можно взять из старой версии).

- Закомментирован modules/mod_status.so, но используется директива ExtendedStatus. Нужно либо закомментить директиву, либо включить mod_status (сделал второе).
Аватара пользователя
Osvax
Сообщения: 74
Зарегистрирован:
19 мар 2013, 00:54

Osvax » 09 дек 2014, 15:48

Максим писал(а):
Den314 писал(а):Доброй ночи!
Подскажите когда будет обновление phpmyadmin в OpenServer? уже доступна для скачивания pma 4.3.0, а у вас в проекте 4.0.10.6...
Его пока что не будет, 4.3 это другая ветка, а не новая версия. В Open Server используется старая ветка phpmyadmin из-за наличия php старой версии 5.2.

Вот отомрёт php 5.2 через пару лет окончательно, тогда и удалю его из сборки и phpmyadmin можно будет обновить.
Всем привет. Тогда нужно ждать пока отомрет Mysql 5.1 потому что phpmyadmin 4.3 с ним тоже уже не работает)) Я для прикола поставил себе 2 версии phpmyadmin старую и новую и сделал проверку версии php в новой версии. Если версия PHP ниже 5.3 редирект на старую версию и все) Хотя сам все равно в phpmyadmin базы и пользователей создаю, а пользуюсь dbForge Studio for Mysql (она есть бесплатная для некоммерческого использования). Ну это так, для тех кому очень надо новую версию :)

[upd=1418130628][/upd]
hudson писал(а):Несколько ошибочек по конфигурации "Apache-2.2+Nginx-1.6" в 5.2.0

- В конфигурации есть загрузка модуля rpaf_module, но modules/mod_rpaf.so отсутствует (можно взять из старой версии).

- Закомментирован modules/mod_status.so, но используется директива ExtendedStatus. Нужно либо закомментить директиву, либо включить mod_status (сделал второе).
Здравствуйте. А можете сделать вложение данного модуля, для тех кто уже удалил старую версию.
AVATOR
Сообщения: 116
Зарегистрирован:
23 май 2013, 00:25
Откуда: Ukraine

AVATOR » 09 дек 2014, 16:36

Я использую Mysql 5.6 и для базы с php я передаю timezone
time_zone = 'Europe/Kiev'
и у меня выдаёт ошибку что такой timezone не знает. Нашел описание http://stackoverflow.com/a/22848483/2935495 и после того как скачал ( от сюда http://dev.mysql.com/downloads/timezones.html ) архив и скопировал из архива все файлы с заменой сюда
 D:\OS\userdata\MySQL-5.6\mysql\
все стало работать нормально.

Предлагаю сразу закинуть эти файлы в базу.

З.Ы.: на других версиях mysql не пробовал
Аватара пользователя
hudson
Сообщения: 50
Зарегистрирован:
30 май 2012, 19:25

hudson » 09 дек 2014, 17:02

Osvax писал(а):Здравствуйте. А можете сделать вложение данного модуля, для тех кто уже удалил старую версию.
Вот мой mod_rpaf. В идеале надо было поискать для той же версии апача, но лень стало. Как вариант - его вообще можно отключить, а конфигурацию завернуть в IfModule, он полезный, при использовании фронтэнда (nginx), но не обязательный.
Вложения
mod_rpaf.zip
mod_rpaf от Apache-2.2.26
(4.33 КБ) 35 скачиваний
Закрыто