Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 017 607 раз!

Форум

Добро пожаловать, Гость!

Сайты грузятся слишком долго

Обсуждение проблем в работе программного комплекса
Gouvere
Сообщения: 3
C нами: 2 года 5 мес
Откуда: Россия, Иркутск

Непрочитанное сообщение Gouvere » 26 июн 2014, 18:00

В общем, есть у меня старый компьютер, покупал в 2006.
1.5гб RAM, 1.8Ггц, Windows 7 x32

Open Server на нем работал отлично. Не было никаких притензий.
На этой неделе купил ноутбук.
4гб RAM, 3.2Ггц, Windows 8 x64


Начал ставить на него OpenServer. Сначала была такая проблема: hosts-файл не изменялся. Не мог зайти на другие домены, кроме localhost. Решил проблему, запустив OpenServer в режиме администратора.
Теперь другая проблема. Перенес все свои сайты со старого компьютера на ноутбук. Казалось бы, сайты должны грузиться быстрее, ведь машина мощнее. А они теперь намного раз дольше грузятся. Я измерял: моя CMS грузится 1.0015 сек. А на старом компьютере она же грузится за 0.0015 сек. Выходит, разница в целую секунду. Жутко неудобно.
Почему так? Может из-за разницы в разрядности ОС? localhost загружается быстро. Остальные - 1 секунда.

Аватара пользователя
Максим
Сообщения: 4871
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 26 июн 2014, 18:06

Gouvere писал(а):Почему так?


Потому что вы не любите читать руководство пользователя к тому софту, которым вы пользуетесь. Прочтите руководство и когда вы сделаете то, что нужно, то наконец ощутите мощь своего ноутбука.

Длительное подключение к MySQL (более 1 сек)

Перед началом использования Open Server следует отключить протокол IPv6 через [Меню → Закладки → Фиксы реестра → Отключение IPv6]. Если этого не сделать, то процесс подключения в MySQL серверу может выполняться очень долго (более 1 сек) и скорость выполнения php скриптов вас не порадует.


Примените фикс, перезагрузите машину и будет вам счастье. Банить вас не буду, но предупреждение.

Gouvere
Сообщения: 3
C нами: 2 года 5 мес
Откуда: Россия, Иркутск

Непрочитанное сообщение Gouvere » 26 июн 2014, 18:48

Максим писал(а):Длительное подключение к MySQL (более 1 сек)

Перед началом использования Open Server следует отключить протокол IPv6 через [Меню → Закладки → Фиксы реестра → Отключение IPv6]. Если этого не сделать, то процесс подключения в MySQL серверу может выполняться очень долго (более 1 сек) и скорость выполнения php скриптов вас не порадует.


Спасибо большое! Я просто думал, что моя проблема - единичный случай, поэтому не стал туда заглядывать)

Аватара пользователя
DelphinPRO
Сообщения: 637
C нами: 4 года 10 мес
Откуда: Самара
Контакты:

Непрочитанное сообщение DelphinPRO » 26 июн 2014, 21:56

IPv6 иногда нужен на компе (как в моем случае).
Поэтому стоит упомянуть и альтернативный способ, без его отключения -
в настройках подключения к БД вашего сайта вместо имени хоста (localhost) указывать IP-адрес (127.0.0.1)

Gouvere
Сообщения: 3
C нами: 2 года 5 мес
Откуда: Россия, Иркутск

Непрочитанное сообщение Gouvere » 27 июн 2014, 08:58

DelphinPRO писал(а):в настройках подключения к БД вашего сайта вместо имени хоста (localhost) указывать IP-адрес (127.0.0.1)


Спасибо!)

art4mac
Сообщения: 10
C нами: 2 года 10 мес

Непрочитанное сообщение art4mac » 06 апр 2015, 14:37

Отключил IPv6, но так и не помогло. :( В подключении БД стоит хост 127.0.0.1

А в сборке 5.2.2 вообще отсутствует %realprogdir%\modules\system\ipv6_fix.reg

Аватара пользователя
Максим
Сообщения: 4871
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 06 апр 2015, 14:46

art4mac, Сейчас всё делается через "Первый запуск". И медленная работа вашего сайта может быть вообще никак не связана с БД.

art4mac
Сообщения: 10
C нами: 2 года 10 мес

Непрочитанное сообщение art4mac » 06 апр 2015, 16:21

Понятно. Спасибо. Думал, может все-таки что-то надо донастроить. Тот же сайт на Денвере быстро работает.

shamansky
Сообщения: 2
C нами: 1 год 2 мес

Непрочитанное сообщение shamansky » 12 сен 2015, 02:09

Ребятки, я читал доки, но не могу найти, где находятся эти настройки?
[Меню → Закладки → Фиксы реестра → Отключение IPv6]
Вложения
SeF39DoF.png
SeF39DoF.png (13.07 КБ) 1538 просмотров

Аватара пользователя
Максим
Сообщения: 4871
C нами: 5 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 12 сен 2015, 02:19

shamansky, доки хорошо читали? Пункт "Первый запуск" после этого выполняли? Если да, то Ipv6 у вас уже отключено (точнее там просто перенастраивается DNS на предпочтение IPv4).


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 0 гостей