Логотип   Простое и понятное управление
  Уникальные возможности по настройке
  Open Server скачали уже 1 375 397 раз!

Форум

Добро пожаловать, Гость!

Прекращена работа "Apache HTTP Server"

Обсуждение проблем в работе программного комплекса
Kamik
Сообщения: 4
C нами: 2 года 6 мес

Непрочитанное сообщение Kamik » 05 май 2015, 08:06

Я это делал не в OpenServer. Просто сюда меня вывел вопрос у гугла про данную ошибку. Решил отписаться, ибо это был единственный русскоязычный форум. Все ссылки вели на кучу англоязычной техдокументации и багрепорты.
Дико извиняюсь за протуп с мегабайтами-гигабайтами. Почувствовал себя идиотом

Артём Анатольевич
Сообщения: 26
C нами: 1 год 7 мес

Непрочитанное сообщение Артём Анатольевич » 23 мар 2016, 15:08

у меня такая проблема была при активации функций автостарта сервера и автозапуска одновременно с windows, исчезала после их отключения, но не очень всегда удобно запускать и стартовать сервак со значка

dimadav
Сообщения: 10
C нами: 5 лет 2 мес

Непрочитанное сообщение dimadav » 24 мар 2016, 12:28

в конфигурации PHP 5.2 Apache 2.2
windows 7 -64
падает apache
обновил (понизил) вручную версию PHP до 5.2.11 , полет нормальный

Аватара пользователя
djasonx
Сообщения: 12
C нами: 2 года 9 мес

Непрочитанное сообщение djasonx » 31 мар 2017, 18:14

Здравствуйте. У меня следующая проблема. Возникает ниже приведенная ошибка.
Сигнатура проблемы:
Имя события проблемы: APPCRASH
Имя приложения: httpd.exe
Версия приложения: 2.2.31.0
Отметка времени приложения: 55a77942
Имя модуля с ошибкой: LIBEAY32.dll
Версия модуля с ошибкой: 1.0.1.16
Отметка времени модуля с ошибкой: 55a2477e
Код исключения: c0000005
Смещение исключения: 000409ab
Версия ОС: 6.1.7601.2.1.0.256.1
Код языка: 1049
Дополнительные сведения 1: 0a9e
Дополнительные сведения 2: 0a9e372d3b4ad19135b953a78882e789
Дополнительные сведения 3: 0a9e
Дополнительные сведения 4: 0a9e372d3b4ad19135b953a78882e789

использую асимметричное шифрование в связке с javascript (JSEncrypt()) и php (openssl)
js:
$('#but').click(function(){
    var pub_key  =
    '-----BEGIN PUBLIC KEY-----\
    MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDjz8pBU5S9jJRu1eTpr6ZYFCc9\
    TXWecwDeUS/JjCm2R01zecavJPZJvFefkF8uP+LHaCVyyb/jcxN86zGLXMBeaBmu\
    K2TZwyx5/fIcEwxJ7T3M1xhJj4RY2tKgv9LW5joYoncFn+QeahpNGtgs4PrWJTyo\
    OJIwvPg9y7jBSZoyawIDAQAB\
    -----END PUBLIC KEY-----';
    crypt = new JSEncrypt();
    crypt.setPublicKey(pub_key);
    var data = $('#data').val(),//считываем данные
             crupt = crypt.encrypt(data);//шифруем данные
    $.ajax({
        url: 'engine/system/decode.php',
        type: 'post',
        dataType: 'text',
        data: {crupt: crupt},
        success: function(a){
        $('#reply').text(a);
        }
    });
});

php:
$pk  = openssl_get_privatekey($priv_key);
openssl_private_decrypt(base64_decode($data), $out, $pk);
echo $out;

На стороне клиента, все хорошо шифруется, я проверял данные, а при отправке Apache вышибает с этой ошибкой, если экранировать функцию openssl_private_decrypt() ошибки не происходит, собственно как и декодирования. В чем дело не понимаю что их связывает эту ошибку и Apache, как решить проблему?

JUS
Сообщения: 3
C нами: 6 мес 1 день

Непрочитанное сообщение JUS » 21 май 2017, 12:21

Возникает та же ошибка при установке webasyst
Сигнатура проблемы:
Имя события проблемы: APPCRASH
Имя приложения: httpd.exe
Версия приложения: 2.4.25.0
Отметка времени приложения: 58591bec
Имя модуля с ошибкой: php5ts.dll
Версия модуля с ошибкой: 5.5.38.0
Отметка времени модуля с ошибкой: 578fc4d8
Код исключения: c0000005
Смещение исключения: 0003b0ea
Версия ОС: 6.1.7601.2.1.0.256.1
Код языка: 1049
Дополнительные сведения 1: 0a9e
Дополнительные сведения 2: 0a9e372d3b4ad19135b953a78882e789
Дополнительные сведения 3: 0a9e
Дополнительные сведения 4: 0a9e372d3b4ad19135b953a78882e789

Apache 2.4
Php 5.5

Аватара пользователя
Максим
Сообщения: 5196
C нами: 6 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 22 май 2017, 16:09

JUS, у них видимо криворукие разработчики. Пишут что требуется PHP 5.2, а по факту работает только на PHP 7 и выше. Просто смените версию PHP в настройках Open Server.

JUS
Сообщения: 3
C нами: 6 мес 1 день

Непрочитанное сообщение JUS » 23 май 2017, 12:00

Максим писал(а):JUS, у них видимо криворукие разработчики. Пишут что требуется PHP 5.2, а по факту работает только на PHP 7 и выше. Просто смените версию PHP в настройках Open Server.

Максим, спасибо за ответ!
меняю версию
php на 7,0
При этом apache 2,4 применить я не могу, выдает ошибку, что 2,4 совместимо только с php 5.5/5.6
В итоге php 5.7
Apache -PHP-7
MySQl-5.7
При таких настройках apache не вылетает, но и ничего не грузит , после нажатия кнопки "Продолжить"

Аватара пользователя
Максим
Сообщения: 5196
C нами: 6 лет 11 мес
Контакты:

Непрочитанное сообщение Максим » 23 май 2017, 13:39

JUS, сотрите все файлы webasyst с домена и по новой распакуйте нетронутые файлы установщика. Тогда установка пойдёт. Проверил.

JUS
Сообщения: 3
C нами: 6 мес 1 день

Непрочитанное сообщение JUS » 23 май 2017, 18:14

Максим, Большое спасибо. Действительно ошибка была в файлах webasyst.


Вернуться в «Ошибки Open Server»

Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и 1 гость