IE не открывает локальные сайты

Обсуждение других вопросов связанных с веб-разработкой
SkyDreamer
Сообщения: 5
Зарегистрирован:
11 фев 2013, 16:35

IE не открывает локальные сайты

SkyDreamer » 15 окт 2013, 10:58

Всем привет.

Поставил Windows 8.1 Preview, где Internet Explorer 11 идет по стандарту.

Проблема в том, что IE не открывает сайты расположенные на 127.0.0.1, как будто в hosts вообще не смотрит.

Кто с этим сталкивался, как это пофиксить?


P.S. Проблем с другими браузерами нет, IE используется исключительно для тестирования сайтов
Аватара пользователя
Максим
Сообщения: 5408
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 15 окт 2013, 11:07

Всё что угодно может быть. У меня такое было например если не отключить IPv6 согласно инструкции, тогда сайты тупо висли из-за PHP. А еще было например из-за запуска в виртуальной машине, в ней IE адски глючит, приходилось несколько раз машину перезапускать IE то работал то нет. Еще раз помогло удалить и создать файл HOSTS заново (всё это в инструкции к Open Server есть).

А что конкретно у вас там, тут никто не знает :| Ищите проблему, экстрасенсов тут нет. Если не найдете, могу помочь через тимвьювер, однако буду свободен только ближе к вечеру, доступ можно скинуть в личку.
SkyDreamer
Сообщения: 5
Зарегистрирован:
11 фев 2013, 16:35

SkyDreamer » 15 окт 2013, 14:51

В общем разобрался.

Оказывается, в Windows 8.1 IE по умолчанию не открывает локальные сайты.

Как побороть?
1) Заходим в свойства браузера
2) Переходим во вкладку "Безопасность"
3) Нажимаем на иконку "Местная интрасеть"
4) Ставим низкий уровень безопасности
5) Ставим галочку "Включить защищенный режим"
6) Закрываем браузер, при следующем запуске все локальные сайты открываются

Изображение
Аватара пользователя
Максим
Сообщения: 5408
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 15 окт 2013, 18:59

Всё открывается без подобных настроек, но если вам помогло, то рад за вас.
Ответить