Проблемы с пользователями СУБД

Вопросы по работе с Apache, Nginx, PHP, MySQL, Sendmail и т.д.
shurikpris
Сообщения: 1
Зарегистрирован:
10 сен 2012, 02:15

Проблемы с пользователями СУБД

shurikpris » 10 сен 2012, 02:41

В версии 4,6,1. Если создать пользователя нового с паролем то при подключении к базе выдает ошибку Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'users'@'127.0.0.1' (using password: YES)

Хотя при подключении прописываю тот же пароль. В чем может быть проблема??
Аватара пользователя
Dragon_Knight
Сообщения: 581
Зарегистрирован:
10 сен 2012, 02:43
Контактная информация:

Dragon_Knight » 10 сен 2012, 02:53

Присоединяюсь.
Проблема в том, что в phpmyadmin хост указан как localhost, а вот сервер сам при запросе резолвит его в 127.0.0.1

Лечиться это убиранием строчки в конфиге mysql (skip-name-resolve), однако без этой строчки:
5.1.63 - работает на ура.
5.5.27 - падает без причины.

Так-же можно вылечить, если в phpmyadmin указывать не localhost а 127.0.0.1, однако хочеться использовать именно localhost и на версии 5.5.27.


Есть идеи почему падает 5.5.27 ?
phdfoto
Сообщения: 1
Зарегистрирован:
30 сен 2012, 10:00

Создание дополнительных пользователей не работает.

phdfoto » 30 сен 2012, 10:02

Добрый день.

Созданные дополнитеьлные пользователи пока еще не работают.
Работает только root без пароля. Если создаешь другого с любыми привелегиями, он не работает.

Спасибо.
Саня
Сообщения: 1
Зарегистрирован:
13 окт 2012, 01:24

Саня » 13 окт 2012, 01:59

Такая же проблема, создаю других пользователей в phpMyAdmin с любыми привилегиями паролями и без паролей но ответ установщика один Access denied for user 'Alex'@'127.0.0.1' (using password: YES)
а под пользователем root всё работает, как это можно исправить??
Несколько рас переустанавливал сервер и всё равно одна беда, один рас получилось создать пользователя и базу с одним именем, установка сработала, стал перепроверять создав пользователя точно так же и опять нет доступа, чё за ерунда((((
Версия 4.1.2
Подскажите пожалуйста почему не работает доступ к БД при создании нового пользователя????
Аватара пользователя
Максим
Сообщения: 5385
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 13 окт 2012, 02:14

:shock: :mrgreen: Ух ты сколько тут новичков собралось. Переписывайтесь между собой в этой теме, у вас тут своя тусовка будет... гы

P.S. Советую всем пишущим в эту тему почитать документацию к MySQL и наконец научиться создавать пользователей. Откройте для себя магический знак % который нужно указывать в поле Хост (Host) при создании юзера, он разрешает подключение с любого IP...
readonly
Сообщения: 4
Зарегистрирован:
14 окт 2012, 12:04

readonly » 14 окт 2012, 12:49

У меня подобная проблема была на Убунте (бейте меня виндузятники!). Создавал новых юзером через PhpMyAdmin, но потом от их имени даже войти в PhpMyAdmin не получалось. И было как раз Host % в привилегиях.

Проблема решилась, когда указал созданному юзеру localhost и использовать таблицу с хостами. В тех пор все работает, причем при коннекте к базе указываю любой свой хост. А в Open Server на винде таких проблем не было, сразу все без проблем работало с Host %, но у меня версия 4.5.9
Ответить