Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Gauss
Сообщения: 4
Зарегистрирован:
13 дек 2012, 23:38

Gauss » 16 мар 2013, 12:19

Только что обновился до 4.8.2.
ОСь - Win7 Ultimate x32.
Антивирус - eset smart security (Open Server.exe в правила добавлен)
Конфиг
[main]
start=10
allow=1
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
mysql_driver=MySQL-5.5.28
pg_driver=PostgreSQL-9.2.3
mongo_driver=MongoDB-2.2.3(Win7+)
dbdriver1=1
dbdriver2=0
dbdriver3=0
mysqlcharset=cp1251_general_ci
phpdriver=PHP-5.4.9
httpdriver=Apache-2.2.24
httpcharset=windows-1251
logreadsize=256
showversion=0
astart=0
crdisk=0
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=1
favorite=0
showswitch=1
debugmode=1
stext=0
sbrowser=0
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser=""
textred=""
filebrowser=""
sfilebrowser=0
upurl=http://open-server.ru/update/
durl=http://open-server.ru/download.html
folders="public_html www\htdocs www http htdocs docs web httpdocs public html site"

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
phpport=9000
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=
smtp_port=
auth_username=
auth_password=
smtp_ssl=0
pop3_server=
pop3_username=
pop3_password=
force_sender=
Отладка (проблема только с мускулем)
1.png
Zord
Сообщения: 161
Зарегистрирован:
01 сен 2012, 20:43
Откуда: Брянск

Zord » 16 мар 2013, 12:21

Почему-то не заменился плейсхолдер %dbdriver%
Аватара пользователя
Максим
Сообщения: 5405
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 16 мар 2013, 12:54

Gauss Вы подсунули старые конфиги в новую версию, а теперь жалуетесь что ничего не работает.
Gauss
Сообщения: 4
Зарегистрирован:
13 дек 2012, 23:38

Gauss » 16 мар 2013, 13:10

Потому что хз как его правильно обновлять
CrazyLamer
Сообщения: 71
Зарегистрирован:
02 ноя 2012, 13:20

CrazyLamer » 19 мар 2013, 10:25

Zord писал(а):Почему-то не заменился плейсхолдер %dbdriver%
Подтверждаю.
OS 4.8.2 %dbdriver% не отрабатывает, в том же скрипте пробовал для эксперимента %phpdriver% отрабатывает нормально.
На пред идущих версиях всё норм.
Шаблон старт скрипта:
echo %realprogdir%\modules\database\%dbdriver%\bin\mysqldump.exe>%realprogdir%\progs\Default\MySqlDump\mysqldump.ini
echo %ip%>%realprogdir%\progs\Default\MySqlDump\mysqlhost.ini
Обработанный старт скрипт:
echo D:\OpenServer\modules\database\%dbdriver%\bin\mysqldump.exe>D:\OpenServer\progs\Default\MySqlDump\mysqldump.ini
echo 0.0.0.0>D:\OpenServer\progs\Default\MySqlDump\mysqlhost.ini
Zord
Сообщения: 161
Зарегистрирован:
01 сен 2012, 20:43
Откуда: Брянск

Zord » 19 мар 2013, 10:54

Обновляли поверх старой версии?
CrazyLamer
Сообщения: 71
Зарегистрирован:
02 ноя 2012, 13:20

CrazyLamer » 19 мар 2013, 10:58

От старой версии только папка domains и конфиг Default_domains.txt больше ничего..
Аватара пользователя
Максим
Сообщения: 5405
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Максим » 19 мар 2013, 11:07

%httpdriver% (имя HTTP модуля)
%phpdriver% (имя PHP модуля)
%mysql_driver% (имя модуля MySQL / MariaDB)
%pg_driver% (имя модуля PostgreSQL)
%mongo_driver% (имя модуля MongoDB)

Нет уже никакого dbdriver, просто забыл в руководстве пользователя поправить.
CrazyLamer
Сообщения: 71
Зарегистрирован:
02 ноя 2012, 13:20

CrazyLamer » 19 мар 2013, 11:13

Спасибо.
Natali
Сообщения: 1
Зарегистрирован:
24 мар 2013, 09:52

Сбой запуска

Natali » 24 мар 2013, 10:17

Здравствуйте. Установила Open Server, при первом запуске выскакивает ошибка: Сбой запуска.
Параметры системы - Windows 7 Максимальная, брадмауэр Windows отключен, антивирус ESET NOD32
Пишет порт 80 занят, если я все правильно делала, в диспетчере нашла что занимает порт. Но я не знаю что дальше делать.
Вложения
Безымянный.png
Безымянный1.png
Безымянный2.png
Ответить