Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
Hvalchen
Сообщения: 2
Зарегистрирован:
06 ноя 2017, 12:24

Re: Сервер не запускается? Пиши СЮДА!

Hvalchen » 21 ноя 2017, 23:18

Столкнулся с такой проблемой при запуске OpenServer>Мои сайты>PageBuilder-2.5 выходит следующее:
Bad Request

Your browser sent a request that this server could not understand.
Additionally, a 400 Bad Request error was encountered while trying to use an ErrorDocument to handle the request.

Как это устранить ?
ziyod
Сообщения: 1
Зарегистрирован:
23 ноя 2017, 07:56

Re: Сервер не запускается? Пиши СЮДА!

ziyod » 23 ноя 2017, 08:05

Доброе утро, локальный сайт перестал запускаться, точнее все что имеются, ошибка:
Parse error: syntax error, unexpected '<' in D:\OSPanel\userdata\temp\theA054.tmp on line 2 / на линии 2 просто открывается тег <?php и не закрывается, добавит закрытий тег или удалить открывающий не вариант так как .tmp файл всегда меняется !
Нашел выход только для админки это - переименование название папки установленной темы ! Но как вернуть все обратно в рабочее состояние ? в гугле ответов не нашел ( помогите пожалуйста, спасибо заранее !
vruzin
Сообщения: 5
Зарегистрирован:
23 ноя 2017, 22:03

если включить PostgreSQL сервер не запускается.

vruzin » 23 ноя 2017, 22:09

PostgreSQL - в первый раз запускаю. До этого не использовал.

Как только включаю PostgreSQL сохраняю, сервер пытается перезапуститься и все, не работает.
В чем может быть дело?
Начало процедуры запуска сервера
Обновление Hosts файла
Обновление конфигурации MariaDB-10.2-x64
Обновление конфигурации Sendmail
Обновление конфигурации PHP-7.1-x64
Обновление конфигурации PHPPgAdmin
Обновление конфигурации PHPMyAdmin
Обновление конфигурации Apache-PHP-7-x64
Запуск PostgreSQL-9.2-x64
Запуск MariaDB-10.2-x64
Запуск Apache-PHP-7-x64
Проверка состояния сервера
Не удалось запустить PostgreSQL-9.2-x64
Сбой запуска!
--------------------------------------------
Начало процедуры остановки сервера
Остановка системных модулей
Отключение виртуального диска
Сервер успешно остановлен за 1,75 секунд!
Аватара пользователя
ERserver
Сообщения: 74
Зарегистрирован:
03 авг 2015, 02:19

Re: если включить PostgreSQL сервер не запускается.

ERserver » 24 ноя 2017, 01:01

Если есть возможность, то попробуйте в модулях отметить галочку, вести логи запуска PostgreSQL, и потом посмотрите логи ошибок.
Если без него работает сервер?
Аватара пользователя
Максим
Сообщения: 5385
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Сервер не запускается? Пиши СЮДА!

Максим » 24 ноя 2017, 02:09

vruzin, прочтите первое сообщение темы и оформите как положено.
vruzin
Сообщения: 5
Зарегистрирован:
23 ноя 2017, 22:03

Re: если включить PostgreSQL сервер не запускается.

vruzin » 25 ноя 2017, 11:48

ERserver писал(а):Если есть возможность, то попробуйте в модулях отметить галочку, вести логи запуска PostgreSQL, и потом посмотрите логи ошибок.
Если без него работает сервер?
Пробовал. Лог файл даже не создается.
vruzin
Сообщения: 5
Зарегистрирован:
23 ноя 2017, 22:03

Re: Сервер не запускается? Пиши СЮДА!

vruzin » 25 ноя 2017, 11:48

Максим писал(а):vruzin, прочтите первое сообщение темы и оформите как положено.
Благодарю!
Аватара пользователя
Ink0gnit0
Сообщения: 89
Зарегистрирован:
17 мар 2013, 21:16

Re: Сервер не запускается? Пиши СЮДА!

Ink0gnit0 » 25 ноя 2017, 22:09

vruzin,
Сохраните скрипт, приведённый ниже, в CMD-файл. Запустите его и смотрите, где "спотыкается" сервер.
@echo off
setlocal
set PG_EXEC=C:\openserver\modules\database\PostgreSQL-9.2-x64\bin\postgres.exe
set PG_DATA=C:\openserver\userdata\PostgreSQL-9.2-x64\

%PG_EXEC% -d5 -D %PG_DATA%
pause
vruzin
Сообщения: 5
Зарегистрирован:
23 ноя 2017, 22:03

Re: Сервер не запускается? Пиши СЮДА!

vruzin » 27 ноя 2017, 13:01

Ink0gnit0 писал(а):vruzin,
Сохраните скрипт, приведённый ниже, в CMD-файл. Запустите его и смотрите, где "спотыкается" сервер.
@echo off
setlocal
set PG_EXEC=C:\openserver\modules\database\PostgreSQL-9.2-x64\bin\postgres.exe
set PG_DATA=C:\openserver\userdata\PostgreSQL-9.2-x64\

%PG_EXEC% -d5 -D %PG_DATA%
pause

ммм.... не знаю как восмотреть. вот что пишет: http://take.ms/hJrhp
Аватара пользователя
Ink0gnit0
Сообщения: 89
Зарегистрирован:
17 мар 2013, 21:16

Re: Сервер не запускается? Пиши СЮДА!

Ink0gnit0 » 27 ноя 2017, 17:57

vruzin,
Добавьте команду "chcp 1251" вслед за "setlocal". Запустите, проверьте. Если всё же будет некорректно отображаться, замените значение 1251 на 65001.
Ответить