Сервер не запускается? Пиши СЮДА!

Обсуждение проблем в работе программного комплекса
desad
Сообщения: 3
Зарегистрирован:
21 дек 2017, 14:01

Re: Сервер не запускается? Пиши СЮДА!

desad » 21 дек 2017, 17:33

Максим писал(а):desad, попробуйте установить дополнительные библиотеки еще раз, но уже не через меню программы, а вручную.

Вручную запустить:
/modules/system/setup-0.bat (от имени администратора)
/modules/system/setup-1.exe
/modules/system/setup-2.exe
+ перезагрузка компьютера.
сделал все как вы сказали. нет желаемых результатов. те же ошибки. что делать дальше?
Аватара пользователя
Максим
Сообщения: 5385
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Сервер не запускается? Пиши СЮДА!

Максим » 21 дек 2017, 18:36

desad, значит у вас не хватает других библиотек или повреждены какие-то системные файлы. В принципе здесь всё хорошо описано как и что делать: http://pcpro100.info/oshibka-pri-zapusk ... xc000007b/
LVC2
Сообщения: 1
Зарегистрирован:
13 апр 2016, 15:02

Re: Сервер не запускается? Пиши СЮДА!

LVC2 » 30 дек 2017, 20:12

Доброго времени суток!

Может тут где то и писалось уже такое, но не наткнулся на это.

Происходит проблема с запуском сервера в обычном режиме, PHP7, PHP7.1, PHP5.6, PHP5.5 (32/64) и apache 2.4, apache php 7 (32/64). Но если поставить галочку в отладочном режиме, то он запускается без проблем.

Win 7 Ultimate x64, Антивируса нет, брандмауэр отключен, админстратор
2017-12-30 22:05:09  --------------------------------------------
2017-12-30 22:05:09  Начало процедуры запуска сервера
2017-12-30 22:05:10  Обновление Hosts файла
2017-12-30 22:05:10  Обновление конфигурации MySQL-5.7-x64
2017-12-30 22:05:10  Обновление конфигурации Sendmail
2017-12-30 22:05:10  Обновление конфигурации PHP-7.1-x64
2017-12-30 22:05:10  Обновление конфигурации PHPMyAdmin
2017-12-30 22:05:10  Обновление конфигурации Apache-PHP-7-x64
2017-12-30 22:05:10  Запуск MySQL-5.7-x64
2017-12-30 22:05:10  Запуск Apache-PHP-7-x64
2017-12-30 22:05:10  Проверка состояния сервера
2017-12-30 22:05:42  Не удалось запустить Apache-PHP-7-x64
2017-12-30 22:05:42  Сбой запуска!
2017-12-30 22:05:42  --------------------------------------------
2017-12-30 22:05:42  Начало процедуры остановки сервера
2017-12-30 22:05:42  Остановка системных модулей
2017-12-30 22:05:44  Отключение виртуального диска
2017-12-30 22:05:44  Сервер успешно остановлен за 1,186 секунд!
Denis WDS
Сообщения: 2
Зарегистрирован:
09 янв 2018, 11:07

Сервер не запускается?

Denis WDS » 09 янв 2018, 11:45

Приветствую!

До сегодня все работало нормально. Работал с сайтом - завис комп. Помогла только перезагрузка с кнопки. После этого перестало запускаться. Если переставляю MySQL на 5.7 например, то все запускается, но баз данных соответственно нет. А как их перенести без PHPMyAdmin я не знаю. Ошибок никаких не выскакивает(((

1. Скрины консоли в отладочном режиме - после нажатия любой клавиши окна пропадают но сервер не запускается. Скрин в конце сообщения!!!!

[img]
Consol_OSPanel_run.png
[/img]

2. Содержимое файла userdata\profiles\Default.ini
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=1
mysql_log=1
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-5.5"
httpdriver="Apache-2.4"
mysql_driver="MySQL-5.6"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=0
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=0
favorite=0
showswitch=1
debugmode=1
stext=1
sbrowser=1
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser="%realprogdir%\progs\_Internet\GoogleChromePortable\GoogleChromePortable.exe"
textred="%realprogdir%\progs\_Office\Notepad++\notepad++.exe"
filebrowser=""
sfilebrowser=0
maxrequests=0
folders=""

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""
3. Параметры системы

Win10 Pro Build 16299.rs3_release.170928-1534
administrator
Avast Free Antivirus

4. Логи

Основной
2018-01-09 11:12:17  --------------------------------------------
2018-01-09 11:12:17  Начало процедуры запуска сервера
2018-01-09 11:12:17  Обновление Hosts файла
2018-01-09 11:12:17  Обновление конфигурации MySQL-5.6
2018-01-09 11:12:17  Обновление конфигурации Sendmail
2018-01-09 11:12:17  Обновление конфигурации PHP-5.5
2018-01-09 11:12:17  Обновление конфигурации PHPMyAdmin
2018-01-09 11:12:17  Обновление конфигурации Apache-2.4
2018-01-09 11:12:17  Запуск MySQL-5.6
2018-01-09 11:12:17  Запуск Apache-2.4
2018-01-09 11:12:17  Проверка состояния сервера
2018-01-09 11:12:56  Не удалось запустить MySQL-5.6
2018-01-09 11:12:56  Сбой запуска!
2018-01-09 11:12:56  --------------------------------------------
2018-01-09 11:12:56  Начало процедуры остановки сервера
2018-01-09 11:12:56  Остановка системных модулей
2018-01-09 11:12:57  Отключение виртуального диска
2018-01-09 11:12:57  Сервер успешно остановлен за 0,578 секунд!
Apache запросы
-пусто-

Apache отладка
[Tue Jan 09 11:12:18.533655 2018] [ssl:warn] [pid 2112:tid 568] AH01909: espero:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:18.536155 2018] [ssl:warn] [pid 2112:tid 568] AH01909: ag-beauty:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:18.537155 2018] [ssl:warn] [pid 2112:tid 568] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:18.759180 2018] [ssl:warn] [pid 2112:tid 568] AH01909: espero:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:18.760682 2018] [ssl:warn] [pid 2112:tid 568] AH01909: ag-beauty:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:18.761687 2018] [ssl:warn] [pid 2112:tid 568] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:18.803215 2018] [mpm_winnt:notice] [pid 2112:tid 568] AH00455: Apache/2.4.27 (Win32) OpenSSL/1.0.2l configured -- resuming normal operations
[Tue Jan 09 11:12:18.803215 2018] [mpm_winnt:notice] [pid 2112:tid 568] AH00456: Apache Lounge VC11 Server built: Jul 10 2017 13:23:43
[Tue Jan 09 11:12:18.803215 2018] [core:notice] [pid 2112:tid 568] AH00094: Command line: 'd:\\dropbox\\ospanel\\modules\\http\\Apache-2.4\\bin\\httpd.exe -d D:/Dropbox/OSPanel/modules/http/Apache-2.4 -f d:\\dropbox\\ospanel\\modules\\http\\Apache-2.4\\conf\\httpd.conf'
[Tue Jan 09 11:12:18.814724 2018] [mpm_winnt:notice] [pid 2112:tid 568] AH00418: Parent: Created child process 608
[Tue Jan 09 11:12:19.557219 2018] [ssl:warn] [pid 608:tid 564] AH01909: espero:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:19.559206 2018] [ssl:warn] [pid 608:tid 564] AH01909: ag-beauty:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:19.560218 2018] [ssl:warn] [pid 608:tid 564] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:19.770991 2018] [ssl:warn] [pid 608:tid 564] AH01909: espero:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:19.771991 2018] [ssl:warn] [pid 608:tid 564] AH01909: ag-beauty:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:19.772991 2018] [ssl:warn] [pid 608:tid 564] AH01909: default:443:0 server certificate does NOT include an ID which matches the server name
[Tue Jan 09 11:12:19.810997 2018] [mpm_winnt:notice] [pid 608:tid 564] AH00354: Child: Starting 32 worker threads.
PHP отладка
-пусто-

MySQL запросы
-пусто-

MySQL отладка
2018-01-09 11:12:17 4556 [Note] Plugin 'FEDERATED' is disabled.
2018-01-09 11:12:17 4556 [Note] InnoDB: Using atomics to ref count buffer pool pages
2018-01-09 11:12:17 4556 [Note] InnoDB: The InnoDB memory heap is disabled
2018-01-09 11:12:17 4556 [Note] InnoDB: Mutexes and rw_locks use Windows interlocked functions
2018-01-09 11:12:17 4556 [Note] InnoDB: Memory barrier is not used
2018-01-09 11:12:17 4556 [Note] InnoDB: Compressed tables use zlib 1.2.3
2018-01-09 11:12:17 4556 [Note] InnoDB: Not using CPU crc32 instructions
2018-01-09 11:12:17 4556 [Note] InnoDB: Initializing buffer pool, size = 128.0M
2018-01-09 11:12:17 4556 [Note] InnoDB: Completed initialization of buffer pool
2018-01-09 11:12:17 4556 [Note] InnoDB: Highest supported file format is Barracuda.
2018-01-09 11:12:17 4556 [Note] InnoDB: The log sequence numbers 17982290 and 17982290 in ibdata files do not match the log sequence number 19536663 in the ib_logfiles!
2018-01-09 11:12:17 4556 [Note] InnoDB: Database was not shutdown normally!
2018-01-09 11:12:17 4556 [Note] InnoDB: Starting crash recovery.
2018-01-09 11:12:17 4556 [Note] InnoDB: Reading tablespace information from the .ibd files...
2018-01-09 11:12:17 18ec  InnoDB: Operating system error number 2 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/operating-system-error-codes.html
InnoDB: Error: could not open single-table tablespace file .\ag@002dbeauty\wp_options (
InnoDB: We do not continue the crash recovery, because the table may become
InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it.
InnoDB: To fix the problem and start mysqld:
InnoDB: 1) If there is a permission problem in the file and mysqld cannot
InnoDB: open the file, you should modify the permissions.
InnoDB: 2) If the table is not needed, or you can restore it from a backup,
InnoDB: then you can remove the .ibd file, and InnoDB will do a normal
InnoDB: crash recovery and ignore that table.
InnoDB: 3) If the file system or the disk is broken, and you cannot remove
InnoDB: the .ibd file, you can set innodb_force_recovery > 0 in my.cnf
InnoDB: and force InnoDB to continue crash recovery here.
Почта
-пусто-
Аватара пользователя
Максим
Сообщения: 5385
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Сервер не запускается? Пиши СЮДА!

Максим » 10 янв 2018, 00:40

Denis WDS
Сообщения: 2
Зарегистрирован:
09 янв 2018, 11:07

Re: Сервер не запускается? Пиши СЮДА!

Denis WDS » 10 янв 2018, 12:04

Максим писал(а):Denis WDS, viewtopic.php?p=20147#p20147
Максим приветствую. Я не могу разобраться куда нужно(в какой файл) добавить код:
[mysqld]
innodb_force_recovery = 1
Я просто новичок и не совсем пока могу разобраться.(((
Gemorroj
Сообщения: 12
Зарегистрирован:
31 янв 2012, 12:59

Re: Сервер не запускается? Пиши СЮДА!

Gemorroj » 17 янв 2018, 13:41

Windows 10 x64, админ
Openserver: 5.2.8
Web-сервер: Apache-PHP-7-x64
PHP: PHP-7.1-x64

При старте сервера, в основном логе пишется что все хорошо:
2018-01-17 13:20:31 Запуск Apache-PHP-7-x64
2018-01-17 13:20:31 Проверка состояния сервера
2018-01-17 13:20:32 Cервер успешно запущен за 1,313 секунд!
По факту, крашится Apache:
ext\mongodb\src\libmongoc\src\mongoc\mongoc-init.c:112 _mongoc_do_init(): precondition failed: status == SASL_OK
---
Если из extension отключить "php_mongodb.dll", то работает нормально.
Обновление mongodb на 1.4.0beta1 ситуацию не меняет.
Обновление php до 7.1.13 так же ситуацию не меняет.
---

Даже если в консоли выполнить "php -v", получаем краш php:
Microsoft Windows [Version 10.0.14393]
(c) Корпорация Майкрософт (Microsoft Corporation), 2016. Все права защищены.

s:\OpenServer\modules\php\PHP-7.1-x64>php -v
ext\mongodb\src\libmongoc\src\mongoc\mongoc-init.c:117 _mongoc_do_init(): precondition failed: status == SASL_OK
профиль:
[main]
start=30
allow=1
autowait=0
emformat=txt
maxmemcache=64
cgiprocess=6
pginitencode=UTF8
pginitlocale=Russian_Russia.1251
ip=127.0.0.1
http_log=0
mysql_log=0
postgresql_log=0
mongodb_log=0
dns_log=0
memcache_log=0
redis_log=0
debugmail=0
mysqlcharset=utf8_general_ci
phpdriver="PHP-7.1-x64"
httpdriver="Apache-PHP-7-x64"
mysql_driver="MariaDB-10.2-x64"
pg_driver=none
mongo_driver=none
memcachedriver=none
redisdriver=none
dnsdriver=none
httpcharset=notset
logreadsize=256
showversion=0
astart=0
crdisk=1
crpath=1
crdomain=0
showfvr=0
showprogs=1
hdomains=0
balloon=0
favorite=0
showswitch=1
debugmode=0
stext=0
sbrowser=0
email=0
vdisk=W
selfhosts=0
webdir="domains"
browser=""
textred=""
filebrowser=""
sfilebrowser=0
maxrequests=0
folders="web"

[ports]
mysqlport=3306
postgresqlport=5432
mongodbport=27017
httpport=80
httpsport=443
httpbackport=8080
ftpport=21
sftpport=990
phpport=9000
redisport=6379
memcacheport=11211

[ftp]
ftp=0
ftpcommandtimeout=600
ftpconnecttimeout=60

[sendmail]
smtp_server=""
smtp_port=""
auth_username=""
auth_password=""
smtp_ssl=0
pop3_server=""
pop3_username=""
pop3_password=""
force_sender=""
---
P.S. перепробовал все 1.3.* версии драйвера - не работает, 1.2.* ветка работает.
как вариант, можно пописать сюда https://github.com/mongodb/mongo-php-driver/issues/677
Sanu
Сообщения: 1
Зарегистрирован:
25 янв 2018, 13:14

ошибка из-за отсутствия библиотеки

Sanu » 25 янв 2018, 13:37

Возникает ошибка из-за отсутствия библиотеки.
"ЗАпуск программы невозможен, так как на компьютере отстутствует MSVCR110.dll

Однако файл лежит на месте.
Я проверял по следующим ссылкам
[url]C:\Windows\SysWOW64[/url]
и
[url]C:\Windows\Systеm32[/url]
Аватара пользователя
Максим
Сообщения: 5385
Зарегистрирован:
11 дек 2010, 20:29
Контактная информация:

Re: Сервер не запускается? Пиши СЮДА!

Максим » 25 янв 2018, 21:59

Gemorroj, разработчики php_mongodb.dll уже не первый раз коряво собирают свою dll-ку, с ней постоянно проблемы помню в том году кучу левых svn_*.dll файлов требовала, но если собрать самому то как правило проблема решается. Погуглите, может есть где скачать пересобранную кем-то версию. Либо это баг самой библиотеки.

Sanu, выполните первый запуск и установите библиотеки нужных версий. У вас то файл может и есть, да не той версии что нужно.
Vladi
Сообщения: 2
Зарегистрирован:
28 янв 2018, 21:34

Re: Сервер не запускается? Пиши СЮДА!

Vladi » 28 янв 2018, 21:48

Добрый вечер. У меня проблема. Установил сегодня Open Server. Localhost открывается, а вот что бы я дальше не создавал, уже пишет что:
"Не удается получить доступ к сайту
Не удалось найти IP-адрес сервера new.local.
Возможно, вы имели в виду http://new-local.com/.
Выполните поиск по запросу new local в Google
ERR_NAME_NOT_RESOLVED"
Если поместить новый проект в папку localhost то он отображается в браузере, но другие проекты в других папках с другими названиями нет
Что только не пытался делать, читал руководство, пересмотрел кучу роликов, но увы не могу понять в чем проблема.
ПОМОГИТЕ ПОЖАЛУЙСТА!!!
Вложения
ScreeМЫВМshot_4.jpg
ScreenshАВВИot_3.jpg
Ответить